Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, yesterday I updated the recently released Fedora 18, this has been done:

Packages Altered:
Updated grubby-8.20-1.fc18.x86_64                        @?fedora
Update         8.22-1.fc18.x86_64                        @updates
Updated java-1.7.0-openjdk-1: ?
Update                     1:   @updates
Updated nss-3.14.1-3.fc17.x86_64                         @updates/17
Update      3.14.1-3.fc18.x86_64                         @updates
Updated nss-sysinit-3.14.1-3.fc17.x86_64                 @updates/17
Update              3.14.1-3.fc18.x86_64                 @updates
Updated nss-tools-3.14.1-3.fc17.x86_64                   @updates/17
Update            3.14.1-3.fc18.x86_64                   @updates
Updated xorg-x11-drv-intel-2.20.16-1.fc18.x86_64         ?
Update                     2.20.17-1.fc18.x86_64         @updates

After rebooting today - the sound's gone and Dummy Output is the only device left. So my wild guess would go towards the xorg-x11-drivers .. I tried adding myself to the 'audio' group - but to no avail. It's the usual Intel chipset.

I have no clue where I should begin debugging this, any hints ?

Edit: The older kernel 3.6.11-1.fc17.x86_64 works just fine. It's 3.7.2-201.fc18.x86_64 which is causing the problem.

Edit 2: Today, after booting 3.7.2 up, problem seems to be gone. No clue why.

share|improve this question
up vote 2 down vote accepted

The sound drivers are part of the kernel. Try booting into an older kernel to see if your sound device is restored.

share|improve this answer
When booting up 3.6.11-1.fc17.x86_64 everything's restored to normal. Is there anything I should try out now, in order to make sound work with the most recent kernel ? – tesseract Jan 17 '13 at 12:44
Dunno. But I'd log a bug on RH's Bugzilla. – Ignacio Vazquez-Abrams Jan 17 '13 at 12:51

after upgrading from Fedora17 to fedora18 using FedUp everything worked fine except the Sound...no sound at all.... so reloaded all ALSA and OSS ... and after all configured Kmix soundmixer settings->Audio Hardware Setup -> profile = Analog Stereo output + Digital stereo (IEC 958)input.... that worked...Fedora18 is cool ....

share|improve this answer

i just updated my fedora and sound broke. One of the spdif channels was muted. Took me a bit to find it though.

go into alsamixer and check. at the command line run alsamixer, press F6 and select your sound card, not default. I had 2 sound cards 1, from mb and 1 from video card. Then make sure each of the volume slides DOESNT say MM at the bottom. You can change it by arrowing over to each and press "m" to unmute any channels. Apparently/Somehow i have 5 spdif channels, news to me. When a channel is unmuted it will say 00.

share|improve this answer

What is the output of command:

dmesg | egrep -i "(alsa|sound)"

Mine, for example, is this:

[   16.029463] ALSA sound/pci/hda/hda_intel.c:2848 0000:01:00.1: Handle VGA-switcheroo audio client
[   16.029468] ALSA sound/pci/hda/hda_intel.c:3040 0000:01:00.1: Using LPIB position fix
[   16.031609] ALSA sound/pci/hda/hda_intel.c:1716 0000:01:00.1: Enable sync_write for stable communication
[   16.196847] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input10
[   17.818695] ALSA sound/usb/mixer.c:929 6:0: cannot get min/max values for control 2 (id 6)
[   17.818706] ALSA sound/usb/mixer.c:929 1:0: cannot get min/max values for control 2 (id 1)
[   17.818712] ALSA sound/usb/mixer.c:929 1:0: cannot get min/max values for control 3 (id 1)
[   17.818716] ALSA sound/usb/mixer.c:929 1:0: cannot get min/max values for control 5 (id 1)
[   17.818723] ALSA sound/usb/mixer.c:929 2:0: cannot get min/max values for control 2 (id 2)

Only difference is that I have sound ... using kernel 3.8.2 ... but I cannot enable anything else than 2.0 channels. And also having that Digital Output issue on Sound options ...

The bugzilla issue here:

Maybe you find same lspci entries that could guide you... I hope I gave you some valuable input. Sorry for not answering with fix.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.