Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Due to some other conflicts, I disabled/stopped NetworkManager in Fedora 15,

Now, for network configuration I used system-config-network-gui to config & enable Ethernet interface,

Problem is, when system starts, the Ethernet does not become enabled. Although in configuration through system-config-network, I specifically checked "Activate device when computer starts" "Allow all users to enable and disable the device",

and cleared "Controlled by NetworkManager"

I double checked the config file "/etc/sysconfig/networking/devices/ifcfg-eth0" to see if the configurations are saved correctly and onboot is enabled. And they look OK.

so, Why still it does not become enabled automatically on boot?

# Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
TYPE=Ethernet
IPV6INIT=no
USERCTL=yes
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
NAME="System eth0"
UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
DNS2=4.2.2.4
DNS1=8.8.8.8
IPADDR0=192.168.0.200
PREFIX0=24
GATEWAY0=192.168.0.1
DNS3=192.9.9.3
HWADDR=XX:XX:XX:XX:XX:XX
IPADDR=192.168.0.200
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
NM_CONTROLLED=no
PREFIX=24
share|improve this question
    
Please show /etc/sysconfig/networking/devices/ifcfg-eth0 contents –  dchirikov Jan 15 '13 at 15:53
    
# Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet DEVICE=eth0 ONBOOT=yes BOOTPROTO=none TYPE=Ethernet IPV6INIT=no USERCTL=yes DEFROUTE=yes IPV4_FAILURE_FATAL=yes NAME="System eth0" UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX DNS2=4.2.2.4 DNS1=8.8.8.8 IPADDR0=192.168.0.200 PREFIX0=24 GATEWAY0=192.168.0.1 DNS3=192.9.9.3 HWADDR=XX:XX:XX:XX:XX:XX IPADDR=192.168.0.200 NETMASK=255.255.255.0 GATEWAY=192.168.0.1 NM_CONTROLLED=no PREFIX=24 –  saeed144 Jan 15 '13 at 15:58
    
using the system-config-network-cmd I got furthur with the troubleshooting. It seems that somehow the DNS is mis-configured in the file, although I have always used the system-network-config commands to add DNS server. Here is extract of system-config-network-cmd Component: system-config-network Version: 1.6.2 File "/usr/sbin/system-config-network-cmd", line 292, ValueError: invalid literal for int() with base 10: 24DNS2=4.2.2.4 Local variables in innermost frame: confkey: ONBOOT DevEthernet.Prefix=24DNS2=4.2.2.4 DevEthernet.PrimaryDNS=8.8.8.8 –  saeed144 Jan 16 '13 at 13:36
    
correcting the file, still did not help, and the system boots up without its network interfaces enabled. –  saeed144 Jan 16 '13 at 13:42
add comment

1 Answer 1

BOOTPROTO=static in /etc/sysconfig/networking/devices/ifcfg-eth0 would solve you problem

But it seems that you got a bug described in bugzilla:

ifup doesn't assign address specified with IPADDR0

My recomenration is to use vim or nano for edit /etc/sysconfig/networking/devices/ifcfg-eth0:

# Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
DEVICE=eth0
UUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
HWADDR=XX:XX:XX:XX:XX:XX
NM_CONTROLLED=no
ONBOOT=yes
BOOTPROTO=none
NAME="System eth0"
TYPE=Ethernet
IPADDR=192.168.0.200
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
DNS1=8.8.8.8
DNS2=4.2.2.4
DNS3=192.9.9.3
USERCTL=yes
DEFROUTE=yes
IPV4_FAILURE_FATAL=yes
share|improve this answer
    
Thanks dchirikov, I also changed bootproto=none to bootproto=static I'm testing to see the result. good link to the bugzilla. cheers –  saeed144 Jan 16 '13 at 10:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.