Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I changed my fstab into this:

#
# /etc/fstab
# Created by anaconda on Sat Jan 12 02:12:44 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=fb2b6c2e-a8d7-4855-b109-c9717264da8a /                       ext4    auto,noatime,noload,data=ordered,commit=10,defaults        1 1
UUID=71362665-f627-41e1-a093-de42a0a356e2 /boot                   ext3    defaults        1 2
UUID=8024a5cd-af4b-4776-af0d-65ad80af8649 swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/usr/tmpDSK             /tmp                    ext3    defaults,noauto        0 0
/dev/sdd1               /home4                  auto    auto,noatime,noload,data=ordered,commit=10,defaults        0 0
/dev/sdc1               /home3                  auto    auto,noatime,noload,data=ordered,commit=10,defaults        0 0
/dev/sdb1               /home2                  auto    auto,noatime,noload,data=ordered,commit=10,defaults        0 0

Basically the boot sector remains ext3. I disabled journaling for most drives because it causes heavy writes.

Now after rebooting server I can't even access ssh.

The message I got from ssh is connection refused.

share|improve this question
1  
From what I am understanding, and excuse me if I am wrong, but you think that your server is not coming up thus resulting in the inability to ssh into it? The error can be caused by multiple things. Can you ping the server and does it respond? Do you have physical access to the machine? –  haveyouseenmyname Jan 15 '13 at 2:18
    
Do you have anohter account on the server to test ssh? Maybe you disable root login for ssh. –  John Siu Jan 15 '13 at 2:18
    
ssh ing is refused before I specify the user name. I can ping and tracert. –  Jim Thio Jan 15 '13 at 2:40
    
Do you have remote terminal access? There are too many possibilities and difficult to give suggestion. –  John Siu Jan 15 '13 at 5:26
add comment

1 Answer 1

up vote 3 down vote accepted

I am spotting one potential issue with your fstab, which may also answer your other 2 fstab questions.

Both noload AND data=ordered are useed on the same device.

  1. noload basically means don't load/use journal
  2. data=ordered set journal mode to ordered

So (1) is telling system to don't use journal but (2) is setting up journal mode, conflicting each other.

I cannot be 100% sure if the two option together is actually causing the problem as I don't want to test it on my VM.

share|improve this answer
    
however, I can mount /home2 and /home3 just fine without complain –  Jim Thio Jan 15 '13 at 6:30
    
hmm, maybe I will try it on a spare one later. –  John Siu Jan 15 '13 at 14:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.