Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install package on Redhat 5.5 using YUM but it always give me this error

[root@redhat64 Desktop]# yum install perl-Net-Server-0.97-1.el5.rf.noarch.rpm   Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Examining perl-Net-Server-0.97-1.el5.rf.noarch.rpm: perl-Net-Server-0.97-1.el5.rf.noarch
Marking perl-Net-Server-0.97-1.el5.rf.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package perl-Net-Server.noarch 0:0.97-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package
      Arch      Version          Repository                                Size
================================================================================
Installing:
 perl-Net-Server
      noarch    0.97-1.el5.rf    /perl-Net-Server-0.97-1.el5.rf.noarch    357 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 357 k
Is this ok [y/N]: y
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 6b8d79e6


Public key for perl-Net-Server-0.97-1.el5.rf.noarch.rpm is not installed

Note :: OS is 5.5 64bit running on virtual box and I have set GPGCHECK=0 in local YUM repository.

Output of Repository

[root@redhat64 ~]# cat /etc/yum.repos.d/* | grep -v "^#"
[rhel-debuginfo]
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[rhel-debuginfo-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/beta/$releasever/en/os/$basearch/Debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
[rhel-local.repo]
name=Local Repo
Baseurl=file:///RPMS
enabled=1
gpgcheck=0

Im using the Local.repo as my main packages repository

share|improve this question
    
What does yum localinstall perl-Net-Server-0.97-1.el5.rf.noarch.rpm say? –  dchirikov Jan 14 '13 at 11:36
    
checked what you said but its giving same error as mentioned in last two lines of Question –  OmiPenguin Jan 14 '13 at 11:42
    
Could you add cat /etc/yum.repos.d/* | grep -v "^#" to your Question? –  dchirikov Jan 14 '13 at 11:47

1 Answer 1

up vote 3 down vote accepted

You need to install the Repoforge GPG key:

# rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt
share|improve this answer
    
What this command will do??? But still I tried it and it gave me error error: apt.sw.be/RPM-GPG-KEY.dag.txt: import read failed(-1). –  OmiPenguin Jan 14 '13 at 14:59
1  
Re what it does: It "installs the Repoforge GPG key". That allows yum or rpm to accept packages signed with that key. –  Warren Young Jan 14 '13 at 15:22
1  
Re permission error: I just tried it, and it works here. You do have to do it as root, as indicated by the leading #. –  Warren Young Jan 14 '13 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.