Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I screwed up the lightdm.conf file as superuser.

What I was trying to do: I tried to insert a command (xbacklight -set 50) that sets my monitor brightness at the lightdm config file. Now when I start my laptop, it gets stuck at the xubuntu loading screen, so I can't login.

Is there a way to go into the shell/command-line and fix the lightdm.conf file??

share|improve this question

3 Answers 3

Press Ctrl+Alt+F1 to switch to a different virtual console. You will have a text mode login prompt.

Once you've done your repairs, you can switch back to the virtual console with the X window display by pressing Ctrl+Alt+F7.

If you want to have several terminals, you get 6 virtual consoles with a login prompt by default: press Ctrl+Alt+F2, etc.

share|improve this answer

Boot into recovery mode, when the recovery menu is up, use the "Root Shell" option to gain a shell, then remove the command in the lightdm.conf.

share|improve this answer
    
CTRL ALT F1 did the trick. Thanks anyway. –  user1091856 Jan 14 '13 at 1:40

Got what I needed on Google.

Solution: CTRL + ALT + F1 at the xubuntu loading screen. Then gained access to the shell, used vim to edit the file and then removed the commands I had inserted on it that was preventing lightdm from starting..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.