Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My original goal was setup service-network-ssh on Nexenta Illumos. As a result of the command

apt-get install service-network-ssh

I got the following message

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libstdc++6-4.2-dev : Depends: g++-4.2 (= 4.2.3-2nexenta7) but it is not going to be installed
                      Depends: gcc-4.2-base (= 4.2.3-2nexenta7) but it is not going to be installed
                      Depends: libstdc++6 (>= 4.2.3-2nexenta7) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried to do

apt-get -f install

and received

Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following extra packages will be installed:
  apt apt-utils base-passwd binutils ca-certificates coreutils cpp-4.2 debconf
  debconf-i18n debootstrap diff dpkg ed findutils g++-4.2 gawk gcc-4.2
  gcc-4.2-base gettext-base gnupg gpgv grep hostname lib64gcc1 libbz2-1.0
  libcomerr2 libcurl3-gnutls libdb4.6 libgcc1 libgcrypt11 libgnutls13 libgomp1
  libgpg-error0 libgpmg1 libiconv libidn11 libkrb53 libldap-2.4-2
  liblocale-gettext-perl liblzo2-2 libncurses5 libnspr4 libnspr4-0d libnss3
  libnss3-0d libnss3-1d libopencdk10 libreadline5 libsasl2-2 libsasl2-modules
  libsqlite3-0 libssl0.9.8k libstdc++6 libtasn1-3 libtext-charwidth-perl
  libtext-iconv-perl libtext-wrapi18n-perl libtspi1 lzma makedev nexenta-lu
  nexenta-sunw nexenta-zones perl-base readline-common sed sunwbridgeu
  sunwcakr sunwcar sunwckr sunwcnetr sunwcsl sunwcslr sunwcsr sunwcsu
  sunwgrubr sunwkvm sunwlibm sunwpool sunwpoolr sunwsmapi sunwtecla sunwtoo
  sunwtsg sunwtsr sunwtsu sunwzfsr sunwzfsu sunwzoner sunwzoneu ubuntu-keyring
  zlib1g
Suggested packages:
  apt-doc aptitude synaptic gnome-apt wajig dpkg-dev binutils-doc
  gcc-4.2-locales debconf-doc debconf-utils libgnome2-perl libnet-ldap-perl
  libqt-perl libterm-readline-gnu-perl diff-doc mlocate locate slocate
  g++-4.2-multilib gcc-4.2-doc libstdc++6-4.2-dbg gcc-4.2-multilib libgcc1-dbg
  libgomp1-dbg libmudflap0-4.2-dbg libmudflap0-4.2-dev gnupg-doc xloadimage
  rng-tools gnutls-bin krb5-doc krb5-user libsasl2-modules-gssapi-mit
  libsasl2-modules-gssapi-heimdal libsasl2-modules-ldap libsasl2-modules-otp
  libsasl2-modules-sql
The following NEW packages will be installed:
  apt apt-utils base-passwd binutils ca-certificates coreutils cpp-4.2 debconf
  debconf-i18n debootstrap diff dpkg ed findutils g++-4.2 gawk gcc-4.2
  gcc-4.2-base gettext-base gnupg gpgv grep hostname lib64gcc1 libbz2-1.0
  libcomerr2 libcurl3-gnutls libdb4.6 libgcc1 libgcrypt11 libgnutls13 libgomp1
  libgpg-error0 libgpmg1 libiconv libidn11 libkrb53 libldap-2.4-2
  liblocale-gettext-perl liblzo2-2 libncurses5 libnspr4 libnspr4-0d libnss3
  libnss3-0d libnss3-1d libopencdk10 libreadline5 libsasl2-2 libsasl2-modules
  libsqlite3-0 libssl0.9.8k libstdc++6 libtasn1-3 libtext-charwidth-perl
  libtext-iconv-perl libtext-wrapi18n-perl libtspi1 lzma makedev nexenta-lu
  nexenta-sunw nexenta-zones perl-base readline-common sed sunwbridgeu
  sunwcakr sunwcar sunwckr sunwcnetr sunwcsl sunwcslr sunwcsr sunwcsu
  sunwgrubr sunwkvm sunwlibm sunwpool sunwpoolr sunwsmapi sunwtecla sunwtoo
  sunwtsg sunwtsr sunwtsu sunwzfsr sunwzfsu sunwzoner sunwzoneu ubuntu-keyring
  zlib1g
0 upgraded, 92 newly installed, 0 to remove and 416 not upgraded.
Need to get 0 B/91.4 MB of archives.
After this operation, 83.9 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
E: Could not perform immediate configuration on 'libstdc++6'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Based on the error log of the first command, I tried to remove the package from gсс, to set gсс version 4.2.3 and with the command

apt-get --purge remove developer-gcc-44

I got

Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libstdc++6-4.2-dev : Depends: g++-4.2 (= 4.2.3-2nexenta7) but it is not going to be installed
                      Depends: gcc-4.2-base (= 4.2.3-2nexenta7) but it is not going to be installed
                      Depends: libstdc++6 (>= 4.2.3-2nexenta7) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

In connection with all this there was a question: What to do - to delete gcc manually (and again to set, and then to set ssh through a repository, but my chief considers, what for the Nexenta operating system gcc shall be set through the package manager) or to try to set service-network-ssh manually, not through a repository? If the second option preferable, advise please links to service-network-ssh installation instructions to Nexenta. If with the errors given above, it is possible to be overcome differently, tell as.

share|improve this question
1  
Please don't cross-post. –  Herman Torjussen Jan 12 '13 at 16:53
    
It's also on SF now. The other two are closed, we're leaving this one open –  Michael Mrozek Jan 12 '13 at 19:55
    
It looks like your package sources are messed up. First, run apt-get update then apt-get -f install. Then, post the content of /etc/apt/sources.list and of all the files (if any) in /etc/apt/sources.list.d. –  Gilles Jan 12 '13 at 23:19
    
@Gilles I made, that you advised - didn't help and laid out file /etc/apt/sources.list and etc/apt/sources.list.d folder contents. –  user1851132 Jan 13 '13 at 12:13
add comment

1 Answer 1

The problem is not related to ssh: when you try to install a package, apt first wants to have the database in a clean state, and it isn't. There's a problem with the libstdc++6 package, which isn't configured.

I'm not directly familiar with the error “Could not perform immediate configuration”. A few things you could try:

  • If you have Aptitude, try running it instead of apt-get. In some versions of Debian, aptitude is smarter than apt-get.
  • Try apt-get -o APT::Immediate-Configure=0 -f install
  • Try calling dpkg manually to install the troublesome packages: dpkg --configure -a; dpkg -i /var/cache/apt/archives/libstdc++6*
share|improve this answer
    
What do each of the commands directly dpkg --configure -a; dpkg -i /var/cache/apt/archives/libstdc++6* @Gilles? –  user1851132 Jan 14 '13 at 6:27
    
@user1851132 dpkg --configure -a configures all packages that have been unpacked but not configured, letting dpkg figure out the order. It might help because here apt-get is having trouble performing the installation steps in the right order. dpkg -i … installs the specified package without doing dependency resolution (if a dependency is not met, it will complain, not attempt to resolve it). –  Gilles Jan 14 '13 at 9:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.