Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed Arch i686 on a VirtualBox VM (I have an nvidia GT610). I ran the following commmand as root:

pacman -S nvidia 

After installation and rebooting, I ran

pacman -S xorg-server xorg-xinit xorg-server-utils xorg-twm xorg-xclock xterm

then

startx

I got a fatal error saying No screens found. Any help as to what should I do ?

share|improve this question

1 Answer 1

I Installed Arch in virtualbox

A virtual machine running in vbox uses a emulated video card instead of your nvidia card.

Which means nvidia like driver is unnecessary.

Try X -configure first, which will generate a probed xorg config, but modern Xorg shouldn't need that at all. (If you have /etc/Xorg/xorg.conf, remove it)

share|improve this answer
    
This didn't help. X -configure returns No device to configure. COnfiguration failed. Server terminated with error (2). –  Primož Kralj Jun 20 at 12:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.