Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I prevent the X server from starting up on Fedora 17? In older versions the user should edit /etc/inittab but in this version (I didn't check this on previous versions) Fedora uses some other mechanisms to do that.

share|improve this question
up vote 6 down vote accepted

From the manual online:

systemd uses symlinks to point to the default runlevel. You have to delete the existing symlink first before creating a new one


rm /etc/systemd/system/default.target
ln -sf /lib/systemd/system/multi-user.target /etc/systemd/system/default.target 

To switch back:

rm /etc/systemd/system/default.target
ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target 

You will still get the graphical boot splash. To remove the boot splash, remove "rhgb" from /etc/default/grub...

#GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhbg quiet"
GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 quiet"

and then run grub2-mkconfig...

grub2-mkconfig -o /boot/grub2/grub.cfg

To solve the missing "True" font bug:

Change every occurrence of the word, True, with latarcyrheb-sun16 or latarcyrheb-sun32 in these files:


and then run grub2-mkconfig...

grub2-mkconfig -o /boot/grub2/grub.cfg
share|improve this answer
I applied all of the above but nothing happened and Fedora start graphically. – XinHua Jan 11 '13 at 9:48
@XinHua Hmmm... What to conclude? This works perfectly for Fedora 17. Did you become root first? – Christopher Jan 11 '13 at 13:52
YES! I do it again and it worked. First time I entered grub2-mkconfig without -o /boot/grub2/grub.cfg. – XinHua Jan 11 '13 at 14:20
@XinHua Woo-hoo! Nice catch. – Christopher Jan 11 '13 at 14:21
On a side note, Fedora 19 broke/improved startx. Instead of startx -- :1, do startx -- vt1 where vt1 is a virtual terminal. – djeikyb Jul 9 '13 at 20:24

Fedora uses systemd for maintaining runlevels

# rm /etc/systemd/system/default.target 
# ln -sf /lib/systemd/system/multi-user.target /etc/systemd/system/default.target 
share|improve this answer

Just type the below command:

sudo ln -sf  /lib/systemd/system/multi-user.target \
share|improve this answer
That's already been said in the other two answers to this post. Please don't just repeat stuff, it serves no purpose. – Mat Sep 21 '13 at 15:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.