Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried:

root@host [/home]# yum install iftop
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.mirrors.tds.net
 * extras: yum.singlehop.com
 * updates: mirror.wiredtree.com
Setting up Install Process
No package iftop available.
Error: Nothing to do

So how to do it?

What should I do to be able to do so?

share|improve this question
up vote 6 down vote accepted

You can either download the source code and compile the package yourself, or you can downloaded the binary package for your distribution.

Have a look at http://pkgs.repoforge.org/iftop/ as it provides binary packages for RHEL/CentOS and the source.

To install the binary package on CentOS-6 64-bit just do the following:

wget http://pkgs.repoforge.org/iftop/iftop-0.17-1.el6.rf.x86_64.rpm
rpm -ivh iftop-0.17-1.el6.rf.x86_64.rpm
share|improve this answer
rpm can accept a http or ftp link as the package name. No need to wget. Also, it's best to stick to atleast semi-official repositories like EPEL when possible. – jordanm Jan 10 '13 at 20:19
+1 for both. Can anyone tell me why the 2 answers are different? – Jim Thio Jan 11 '13 at 1:49
I shorten your instruction to: rpm -ivh pkgs.repoforge.org/iftop/iftop-0.17-1.el6.rf.x86_64.rpm – Jim Thio Jan 11 '13 at 3:14
This repo is not maintained anymore and strongly not recommended to use. Use epel instead! Find more information on additional rhel / centos/ oel repos here: wiki.centos.org/PatrickDGarvey/AdditionalResources/Repositories – aim Nov 27 '15 at 23:59

iftop available in EPEL repository:

# rpm -ivh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
share|improve this answer
I did that. Now how to run iftop? I run it and nothing shows up – Jim Thio Jul 11 '14 at 4:36
after adding repository run this: yum install iftop – manuel Mar 13 '15 at 14:23

For Centos 7 you can do this:

rpm -i http://mirror.pnl.gov/epel/7/x86_64/i/iftop-1.0-0.7.pre4.el7.x86_64.rpm
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.