Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use ubuntu 12.04, x86_64, kernel 3.2.0-35-generic. I use KDE desktop. However, under KDE the GTK programs have black background in some areas. e.g. enter image description here How to solve the problem?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Looks like you're using gedit and evince (consider using the native applications for KDE, kwrite and okular respectively), which are both GTK 3.

I had this similar problem and was solved by setting GTK themes in KDE: install the kde-config-gtk package and set the GTK theme (e.g. the Oxygen theme - I don't have an Ubuntu here to check the package name, I think it's oxygen-molecule).

share|improve this answer
    
I don't have this problem using fedora 17 KDE (4.9.4) w/ GTK 3 apps like evince. –  goldilocks Jan 10 '13 at 16:33
1  
I have installed kde-config-gtk. And the problem is indeed caused by the GTK theme QtCurve I set. After QtCurve is changed to oxygen-gtk, the balck areas disappear. –  goodluck Jan 11 '13 at 0:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.