Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I'm doing emerge -avuDN glibc always getting this:

>>> Emerging (1 of 28) sys-libs/glibc-2.15-r3
* glibc-2.15.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                       [ ok ]
* glibc-ports-2.15.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                 [ ok ]
* glibc-2.15-patches-23.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                           [ ok ]
make -s glibc-test 
make -s glibc-test 
* Scanning system for __guard to see if you need to rebuild first ... ...                                                                      [ !! ]
* Your system still has old SSP __guard symbols.  You need to
* rebuild all the packages that provide these files first:
* //bin/busybox
* //sbin/lvm.static
* //sbin/dmsetup.static
* //sbin/dmeventd.static
* //usr/bin/diet
* //usr/bin/dnsd
* //usr/bin/elftrunc
* //usr/sbin/vdu
* //usr/sbin/vps
* //usr/sbin/vtag
* //usr/sbin/nattribute
* //usr/sbin/vattribute
* //usr/sbin/chxid
* //usr/sbin/lsxid
* //usr/sbin/showattr
* //usr/sbin/vkill
* //usr/sbin/vwait
* //usr/sbin/vcontext
* //usr/sbin/setattr
* //usr/sbin/ncontext
* //usr/sbin/exec-cd
* //usr/sbin/vmemctrl
* //usr/sbin/reducecap
* //usr/sbin/vdevmap
* //usr/sbin/vdlimit
* //usr/sbin/vlimit
* //usr/sbin/vsched
* //usr/sbin/vspace 
* //usr/sbin/vuname
* //usr/sbin/vserver-info
* //usr/sbin/vserver-stat
* //usr/sbin/vrsetup
* //usr/sbin/naddress
* //usr/lib64/liblzma.so.0
* ERROR: sys-libs/glibc-2.15-r3 failed (setup phase):
*   old __guard detected
* 
* Call stack:
*              ebuild.sh, line  93:  Called pkg_setup
*   glibc-2.15-r3.ebuild, line 175:  Called eblit-run 'pkg_setup'
*   glibc-2.15-r3.ebuild, line 161:  Called eblit-glibc-pkg_setup
*        pkg_setup.eblit, line 119:  Called die
* The specific snippet of code:
*               die "old __guard detected"
* 
* If you need support, post the output of `emerge --info '=sys-libs/glibc-2.15-r3'`,
* the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.15-r3'`.
* The complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.15---r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.15-r3/temp/die.env'.
* Working directory: '/var/tmp/portage/sys-libs/glibc-2.15-r3'
* S: '/var/tmp/portage/sys-libs/glibc-2.15-r3/work/glibc-2.15'
share|improve this question
    
You need to do what it told you to do: rebuild the packages which provide those specific binaries first. –  Michael Hampton Jan 9 '13 at 15:59
    
done, does not help. which special option should I use when rebuilding its? –  archer Jan 9 '13 at 16:00
    
By "does not help" you mean the error message does not change at all? –  njsg Jan 10 '13 at 16:24
    
absolutelly right. It does not change at all –  archer Jan 10 '13 at 18:09
    
revdep-rebuild –  Heather Jan 17 '13 at 9:48
show 1 more comment

migrated from serverfault.com Jan 10 '13 at 4:57

This question came from our site for professional system and network administrators.

2 Answers

The error message is pretty clear. Some binaries are still using (very) old symbols. You have to rebuild the packages associated with the binaries. The error message gives you a list of these binaries.

Now you can map the binary to a package with q file /bin/busybox (you need app-portage/portage-utils for the q command).

user@host # q file /usr/bin/q
app-portage/portage-utils (/usr/bin/q)

Now emerge the package: emerge -1 app-portage/portage-utils

share|improve this answer
    
I've rebuilt packages and still getting that message. I assume I should rebuild them with some specific gcc configuration (e.g. nopie, nossp). I did that, but problem does not gone. –  archer Jan 16 '13 at 9:49
    
What I have done is. I've unmerged all packages with broken symbol in files, then emerged gcc then emerged back unmerged packages. Although there was system ones and it was risky, it worked. –  archer Mar 14 '13 at 17:55
add comment

The issue, as stated in your emerge output, are the old SSP guards stemming from the listed packages. There are a few approaches to solving the issue depend. Googling around can get you a lot of cases of people working this exact issue. This case looks most similar to the problem you're having:

http://forums.gentoo.org/viewtopic-p-6903712.html?sid=128bdb308c2cb096c464a197a5980936\

I'd start here and then looks into the specifics based on your environment/settings.

share|improve this answer
    
I've already used information found on that thread some time ago. Recompiled all packages with broken SSP with [4] x86_64-pc-linux-gnu-4.5.4-hardenednossp * No effect ;( –  archer Jan 9 '13 at 16:14
    
Can you please suggest me something else? –  archer Jan 16 '13 at 9:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.