Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I got 2 partition I want to mount

sdb1 which uses ext2 file system
sdc1 which uses ext4 file system

I added this 2 line on fstab

/dev/sdb1 /home2 auto auto,noatime,default 0 0
/dev/sdc1 /home3 auto auto,noatime,noload,data=ordered,commit=10,default 0 0

Looks like it's not correct because I fail to mount. How to correct it?

Yet I can't mount them due to some error.

This is my fstab and some command to show that

root@host [/etc]# cat fstab
#
# /etc/fstab
# Created by anaconda on Tue Jan 8 10:16:53 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=eb3b9431-7964-47fd-a497-e4ddcd3f9d05 / ext4 defaults 1 1
UUID=ed11681c-9343-41ac-ac8b-a29bf4d13fbd /boot ext4 defaults 1 2
#UUID=191a3af4-c48a-4779-974a-c55dc290543d /home1 ext4 defaults 1 2
#UUID=eca46a9a-6666-40d0-bbe5-e35b54295264 /home2 ext4 defaults 1 2
UUID=475f3ba3-6459-42ac-b441-1daa95acb2b3 swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/usr/tmpDSK /tmp ext3 defaults,noauto 0 0
/dev/sdb1 /home2 auto auto,noatime,default 0 0
/dev/sdc1 /home3 auto auto,noatime,noload,data=ordered,commit=10,default 0 0
root@host [/etc]# parted -l
Model: ATA WDC WD15EADS-00R (scsi)
Disk /dev/sda: 1500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 525MB 524MB primary ext4 boot
2 525MB 34.4GB 33.8GB primary linux-swap(v1)
3 34.4GB 1500GB 1466GB primary ext4


Model: ATA SAMSUNG SSD 830 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 256GB 256GB primary ext2


Model: ATA M4-CT256M4SSD2 (scsi)
Disk /dev/sdc: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 256GB 256GB primary ext4


root@host [/etc]# mount /home2
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

root@host [/etc]# mount /home3
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

root@host [/etc]#
share|improve this question
    
please give the output of dmesg | tail when you try to mount –  harish.venkat Jan 9 '13 at 16:34
    
And what is at the end of the kernel logs (just use the exact command mount is suggesting) after the failed mounts? –  njsg Jan 9 '13 at 16:35
    
how to get the end of the kernel logs? –  Jim Thio Jan 9 '13 at 16:36
    
root@host [/etc]# dmesg | tail IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 IPv6 addrconf: prefix with wrong length 120 –  Jim Thio Jan 9 '13 at 16:36
add comment

2 Answers

Try this:

/dev/sdb1 /home2 ext2 auto,noatime,defaults 0 0
/dev/sdc1 /home3 ext4 auto,noatime,noload,data=ordered,commit=10,defaults 0 0

'auto' (as you originally had it in your /etc/fstab entries) is not a valid filesystem type.

share|improve this answer
    
auto is a special filesystem-type, but that is intended for other filesystems (man mount to see details afaik). –  Nils Jan 9 '13 at 22:09
    
Not in the various man fstab pages that I am aware of. –  mdpc Jan 10 '13 at 1:32
    
no mdpc. It should be auto. And it's working now. –  Jim Thio Jan 10 '13 at 2:32
    
From man mount on CentOS5: The auto type may be useful for user-mounted floppies. Creating a file /etc/filesystems can be useful to change the probe order (e.g., to try vfat before msdos or ext3 before ext2) or if you use a kernel module autoloader. Warning: the probing uses a heuristic (the presence of appropriate ‘magic’), and could recognize the wrong filesystem type, possibly with catastrophic consequences. If your data is valuable, don’t ask mount to guess. –  Nils Jan 10 '13 at 20:21
    
The last statement however says it all... –  mdpc Jan 10 '13 at 20:23
add comment
up vote 2 down vote accepted

I wonder if I should delete this question. The problem is I use default while I should have written defaults. It's too localized I guess.

share|improve this answer
3  
too localized gets my vote. –  jordanm Jan 9 '13 at 16:53
    
It does appear as if the missing 's' at the end of 'default' would be the cause of your problem. –  Rob Gibson Jan 9 '13 at 16:59
    
Yea that fixed it. Should I let the question stay? There are other answers. In stackoverflow this questions like this are okay. Deleted questions may make everyone look bad. –  Jim Thio Jan 10 '13 at 2:32
1  
Don't delete it. SOmeone might stumble over this and he or she could use that information :) –  Bonsi Scott Jan 10 '13 at 18:47
    
Mark this as answer. But look at my comment to mdpc's answer. You should not use auto. –  Nils Jan 10 '13 at 20:24
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.