Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I had a disk with a full size NTFS partition. I just deleted it and created an EXT4 one.

When it was NTFS, if it wasn't in use (mount but no in use) it was quiet. However now, using EXT4, it is constant reading and I don't know why.

Using EXT3 is fine also.

Any idea?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

This would have been the "lazy initialization" feature of Ext4 which zeroes out the inode tables on the first mount after creating the file system.

This allows the file system to be created faster, but runs a kernel thread called "ext4lazyinit" in the background. You can confirm if this is happening by running "ps aux | grep ext4lazyinit".

The process may take several hours to complete, depending on the size of the file system.

share|improve this answer

you can try to use iostat and iotop to observe processes perfoms io. Also you can turn on io logging echo 1 > /proc/sys/vm/block_dump to examine what happen more clearly

share|improve this answer
Being in idle: sdb1 is constantly writing 2-3M/s associated to [jbd2/sdb1-8]. However sda1 only writes a few K when the process [jbd2/sda3-8] triggers. – yzT Jan 9 '13 at 16:29
What is your mount | egrep "sdb1|sda1". It seems that you need to change commit for monted partition. – dchirikov Jan 9 '13 at 16:52
I left it 1h in idle, and now when I came back it is working as usual, without be writing all the time. Maybe it was indexing or something after format? But indexing what if it had nothing? – yzT Jan 9 '13 at 18:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.