Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just formatted stuff. One disk I format as ext2. The other I want to format as ext4. I want to test how they perform.

Now, how do I know the kind of file system in a partition?

share|improve this question
Out of curiosity, what are you trying to test? Journal vs. no journal? For the record, you can operate ext4 in no-journal mode, and still benefit from all the other new features. – zacharyalexstern Jan 15 '13 at 15:36
up vote 61 down vote accepted

How do I tell what sort of data (what data format) is in a file?
→ Use the file utility.

Here, you want to know the format of data in a device file, so you need to pass the -s flag to tell file not just to say that it's a device file but look at the content. Sometimes you'll need the -L flag as well, if the device file name is a symbolic link. You'll see output like this:

# file -sL /dev/sd*
/dev/sda1: Linux rev 1.0 ext4 filesystem data, UUID=63fa0104-4aab-4dc8-a50d-e2c1bf0fb188 (extents) (large files) (huge files)
/dev/sdb1: Linux rev 1.0 ext2 filesystem data, UUID=b3c82023-78e1-4ad4-b6e0-62355b272166
/dev/sdb2: Linux/i386 swap file (new style), version 1 (4K pages), size 4194303 pages, no label, UUID=3f64308c-19db-4da5-a9a0-db4d7defb80f

Given this sample output, the first disk has one partition and the second disk has two partitions. /dev/sda1 is an ext4 filesystem, /dev/sdb1 is an ext2 filesystem, and /dev/sdb2 is some swap space (about 4GB).

You must run this command as root, because ordinary users may not read disk partitions directly: if needed, add sudo in front.

share|improve this answer
+1: Cuuuute. :) – Warren Young Jan 9 '13 at 18:23
When entering $ sudo file /dev/sda1, I get /dev/sda1: block special – heinrich5991 Jan 10 '13 at 16:55
@heinrich5991 “you need to pass the -s flag …”. I show the command file -s /dev/sd* − with sudo in front, that's sudo file -s /dev/sd*. – Gilles Jan 10 '13 at 16:57
doesn't work for LVM stuff: parted -l seems to work better – TiloBunt Nov 28 '14 at 21:35
@TiloBunt Make that file -sL /dev/mapper/foo-bar, with the -L flag to dereference the symlink. – Gilles Dec 1 '14 at 17:04

Another option is to use blkid:

$ blkid /dev/sda1
/dev/sda1: UUID="625fa1fa-2785-4abc-a15a-bfcc498139d1" TYPE="ext2"

This recognizes most filesystem types and stuff like encrypted partitions.

You can also search for partitions with a given type:

# blkid -t TYPE=ext2
/dev/sda1: UUID="625fa1fa-2785-4abc-a15a-bfcc498139d1" TYPE="ext2" 
/dev/sdb1: UUID="b80153f4-92a1-473f-b7f6-80e601ae21ac" TYPE="ext2"
share|improve this answer
+1: I've verified that this gives the correct result when mounting an ext2 filesystem with mount -t ext4. blkid isn't fooled by that. – Warren Young Jan 9 '13 at 16:45
For what its worth, this also appears to work for xfs drives, though apparently it's blkid is not as great as lsblk is at detecting unmounted drives (if you need to) – Jose Diaz-Gonzalez Mar 4 '15 at 22:41
Thanks! The file command wasn't working, but this gave me what I needed. – Brain2000 Apr 14 at 4:51

You can use sudo parted -l

[shredder12]$ sudo parted -l

Model: ATA WDC WD1600BEVT-7 (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      32.3kB  8587MB  8587MB  primary   ext3            boot
 4      8587MB  40.0GB  31.4GB  primary   ext4
 2      40.0GB  55.0GB  15.0GB  primary   ext4
 3      55.0GB  160GB   105GB   extended
 5      55.0GB  158GB   103GB   logical   ext4
 6      158GB   160GB   1999MB  logical   linux-swap(v1)


share|improve this answer
parted is not installed. Also the drives are not mounted yet. – Jim Thio Jan 9 '13 at 10:45
@JimThio I assume you were able to install it? You should be able to get it by simply doing sudo apt-get install parted (or gparted) if you are on Ubuntu or any other debian derivative. – Karthik T Jan 9 '13 at 12:24
+1: I've verified that this gives the correct result when mounting an ext2 filesystem with mount -t ext4. parted isn't fooled by that. – Warren Young Jan 9 '13 at 16:45
While this is not the most upvoted answer, this is the one I actually use. Also I do not need to specify the device. – Jim Thio Jan 10 '13 at 2:34
Because it is not the best answer: a partition might be grub-labeled as ext2 and contains ext4 filesystem (and then would be mounted as ext4 with mount -t auto) – Basile Starynkevitch Jan 18 at 8:18

Still another way, since you know you're running some flavor of ext?, is to look at the filesystem's feature list:

# tune2fs -l /dev/sda1 | grep features

If in the list you see:

  • extent — it's ext4
  • no extent, but has_journal — it's ext3
  • neither extent nor has_journal — it's ext2

The parted and blkid answers are better if you want these heuristics run for you automatically. (They tell the difference with feature checks, too.) They can also identify non-ext? filesystems.

This method has the virtue of showing you the low-level differences.

The important thing to realize here is that these three filesystems are forwards compatible, and to some extent backwards-compatible, too. Later versions just add features on top of the older ones.

See the ext4 HOWTO for more information on this.

share|improve this answer

try using df -T see man df for more options still one more way I found is cfdisk

share|improve this answer
This has the same weakness as h3rmiller's mount based answer. – Warren Young Jan 9 '13 at 16:38
h3rrmiller removed his answer, so for those who don't have the rep to see it now, the problem is that if you say mount -t ext4 on an ext2 filesystem, df -T reports ext4. That is, it's just reading what the mount table says, not looking at the filesystem metadata to figure this out. – Warren Young Jan 9 '13 at 18:19
@Warren: That's because it is an ext4 filesystem in that case. Just one with not many features. – mattdm Jan 9 '13 at 19:05
@mattdm: So when you unmount it...is it still an ext4 filesystem? – Warren Young Jan 9 '13 at 19:26
@Warren: in a sense, all ext2 filesystems are also ext4 filesystems, yes. (But of course, not in the sense most people mean.) – mattdm Jan 9 '13 at 19:32

fdisk -l will list


fdisk [options] -l list partition table(s) fdisk -s give partition size(s) in blocks fdisk [options] change partition table

share|improve this answer
On what system? fdisk, on the system I'm using at the moment at least, only shows the partition type, not the filesystem type. That means not only can't it tell the difference between ext2, ext3, and ext4, it also can't discern ReiserFS or XFS from these. – Warren Young Jan 9 '13 at 20:17
+1 for effort. I have done fdisk before asking this question. Keep points up. – Jim Thio Jan 10 '13 at 2:35

Surprised this isn't on here already. No sudo required:

lsblk -f

share|improve this answer
If I run this without sudo the FSTYPE column is blank. – Flup Jul 15 '15 at 14:45
@Flup I just tried it myself again and it worked perfectly without sudo. FSTYPE column was fully populated. May be some disparity between our systems? – Freedom_Ben Jul 18 '15 at 1:50
@Flup - you must be using Debian/Ubuntu or derivatives... They're famous for doing something (or maybe not doing something, I wouldn't know) and the end result is you need root privileges to list some lsblk columns... – don_crissti Sep 3 '15 at 22:00

use -T option to print file system type

[root@centos6 ~]# df -T

Filesystem           Type  1K-blocks    Used Available Use% Mounted on
                     ext4    6795192 6367072     76276  99% /
tmpfs                tmpfs    639164       0    639164   0% /dev/shm
/dev/sda1            ext4     487652   28684    433368   7% /boot
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.