Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I am trying to install latest version of glusterfs in Ubuntu by running this command:

apt-add-repository ppa:semiosis/glusterfs-3.2

It does not give any result.

The session won't even close (Ctrl+C not working). I had to close the terminal window to end the session.

Error shown is:

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 88, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/",
        line 80, in get_ppa_info_from_lp
pycurl.error: (28, 'connect() timed out!')
share|improve this question
Seems to be a network problem, try again later or find a different repository for glusterfs. – scai Jan 9 '13 at 6:39
I tried using a proxy also still I am getting the above error – Ajo Mathew Jan 9 '13 at 7:30

1 Answer 1

up vote 1 down vote accepted

see this This PPA is deprecated and will not get any updates. so you may have to use glusterfs-3.3 and for downloading it use this


share|improve this answer
I tried to add the above ppa also not getting output.. it stays there for some time and the above mentioned error is shown – Ajo Mathew Jan 9 '13 at 9:35
are you accessing internet via proxy?? – harish.venkat Jan 9 '13 at 10:27
I have direct connection as well as proxy to run apt-get update commands I have to use proxy. Simple wget {sitename} will revert with out proxy – Ajo Mathew Jan 9 '13 at 10:53
try this export http_proxy=http://<proxy>:<port> export https_proxy=http://<proxy>:<port> sudo -E apt-add-repository ppa:semiosis/ubuntu-glusterfs-3.3 – harish.venkat Jan 9 '13 at 11:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.