Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an AIX server which suddenly stopped servicing SSH connections. When I try to start the service through startsrc -s sshd it says:

0513-059 The sshd Subsystem has been started. Subsystem PID is 258300.

However, right after issuing the command, the services status shows up as inoperative:

 sshd             ssh                           inoperative

The init scripts are well located and throw the same result as above.

EDIT: Here's the odmget command output:

SRCsubsys:
    subsysname = "sshd"
    synonym = ""
    cmdargs = "-D"
    path = "/usr/sbin/sshd"
    uid = 0
    auditid = 0
    standin = "/dev/console"
    standout = "/dev/console"
    standerr = "/dev/console"
    action = 1
    multi = 0
    contact = 2
    svrkey = 0
    svrmtype = 0
    priority = 20
    signorm = 15
    sigforce = 9
    display = 1
    waittime = 20
    grpname = "ssh"

When trying to start the service manually, the following error appears:

exec(): 0509-036 Cannot load program /usr/sbin/sshd because of the following errors:
0509-150   Dependent module libz.a(libz.so.1) could not be loaded.
0509-022 Cannot load module libz.a(libz.so.1).
0509-026 System error: A file or directory in the path name does not exist.

Any help would be greatly appreciated.

share|improve this question
add comment

2 Answers

You can try the following:

1) enable LogLevel DEBUG3 in /etc/ssh/sshd_config

2) add string security.debug /var/log/syslog.security.debug rotate time 1d files 4 to /etc/syslog.conf

3) then

# touch /var/log/syslog.security.debug
# stopsrc -s syslogd
# startsrc -s syslogd
# stopsrc -s sshd
# startsrc -s sshd
share|improve this answer
    
I tried changing what you said, but It didn't shows any useful logging information. I check the log file after restarting syslog and ssh services but there's no information there. –  madprofessor Jan 8 '13 at 19:57
    
Is /var/log/syslog.security.debug empty? Does ps -elf | grep ssh get something? What errpt says? –  dchirikov Jan 8 '13 at 20:00
    
As a matter of fact, the file is empty. errpt does not show any sshd-related entries and ps -elf does not show the process running. Thank you. –  madprofessor Jan 8 '13 at 21:25
    
Does /var/adm/ras/syslog.caa contain some clues? If it doesnt exist touch this file and try to restart sshd. –  dchirikov Jan 8 '13 at 21:27
    
Please provide odmget -q subsysname=sshd SRCsubsys –  dchirikov Jan 8 '13 at 21:33
show 4 more comments

Looks like libz.so.1 is missing on your system.

share|improve this answer
    
Yes, it is. I will restore it to its location to see if it works. –  madprofessor Jan 11 '13 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.