Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just went thru and updated a dozen or so machines from 9.0-RELEASE to 9.1-RELEASE and the last one is dieing during buildworld:

c++  -O2 -pipe -I/usr/src/lib/clang/libclangsema/../../../contrib/llvm/include -I/usr/src/lib/clang/libclangsema/../../../contrib/llvm/tools/clang/include -I/usr/src/lib/clang/libclangsema/../../../contrib/llvm/tools/clang/lib/Sema -I. -I/usr/src/lib/clang/libclangsema/../../../contrib/llvm/../../lib/clang/include -DLLVM_ON_UNIX -DLLVM_ON_FREEBSD -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS -DLLVM_DEFAULT_TARGET_TRIPLE=\"i386-unknown-freebsd9.0\" -DDEFAULT_SYSROOT=\"\" -fstack-protector -fno-exceptions -fno-rtti -c /usr/src/lib/clang/libclangsema/../../../contrib/llvm/tools/clang/lib/Sema/SemaExpr.cpp -o SemaExpr.o
{standard input}: Assembler messages:
{standard input}:108560: Warning: end of file not at end of a line; newline inserted
c++: Internal error: Killed: 9 (program cc1plus)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** Error code 1

Stop in /usr/src/lib/clang/libclangsema.
*** Error code 1

Stop in /usr/src/lib/clang.
*** Error code 1

Stop in /usr/src/lib.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
[Exit 1 ]

Things I have tried:

rm -rf /usr/src/* && cvsup
rm -rf /usr/obj/*

/etc/make.conf is pretty benign at this point with most optimizations turned off:

# Optimize when possible based on CPU
#CPUTYPE?= pentium4

# Set optimization and use pipes to speed up compiles
#CFLAGS= -O -pipe
NO_CPU_CFLAGS=  true    # Don't add -march=<cpu> to CFLAGS automatically
NO_CPU_COPTFLAGS= true  # Don't add -march=<cpu> to COPTFLAGS automatically

# Set kernel compile with special options.
# CFLAGS is not applicable to kernel builds.
#COPTFLAGS= -O -pipe

I'm feeling a little dumb at this point; so any suggestions are welcome.

Thanks for your time.

share|improve this question
1  
Of the things you've tried, you don't say that you tried restarting the make operation. Did you? How much RAM is in the machine? How much swap? (If the compiler is running out of memory, it could explain a compiler crash.) And kind of a last resort, does forcing a single-threaded make help? (make -j1 -B buildworld) I include the latter because a) it would reduce memory use; and b) it just happened to work for me this very afternoon, trying to build cmake on FreeBSD 9.1. :) (Commenting because I have no idea if any of this is the right fix, not having run into it myself.) –  Warren Young Jan 8 '13 at 21:49
    
Thanks. I'll bet you're right about the memory. This is an antique box and I had no idea; but it's only got 384 Mb... [sigh] –  ericx Jan 8 '13 at 22:01
1  
It's easy to test, if you've got several gigs of free disk space to play with. Just add a swap file. I'd suggest 4 GiB. –  Warren Young Jan 9 '13 at 0:08
    
I think clang is a more efficient compiler. You might want to try clang instead of gcc. You should eventually make the switch since fBSD 10 will use clang by default. You can use clang now by modifying your /etc/make.conf –  EhevuTov Jan 9 '13 at 13:34
    
All set. Found some more RAM. btw: I thot 9.x already used clang by default? Thanks for pointing that out. –  ericx Jan 9 '13 at 15:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.