Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I run gcc, it outputs errors but the function names are surrounded by special characters like this ‘setup_connection’:

This same is repeated with variable names. I am wondering if the terminal settings have to be changed. I am currently using ssh to login to the machine.

Any inputs valuable

share|improve this question

closed as unclear what you're asking by Braiam, terdon Oct 11 at 2:21

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
what terminal and font are you using? Have you tried to set the font to console for example? Also check the locale that your system is using. –  BitsOfNix Jan 8 '13 at 12:24
2  
This †looks like UTF-8 as shown on a non-UTF-8 terminal. Try other values for the LANG variable. –  ott-- Jan 8 '13 at 12:47
2  
It really seems that the system is using a locale that's not supported by the terminal / terminal emulator being used, in this case UTF-8 in something that's treating it as iso8859-15. Fix your terminal, or use a locale that it supports. –  njsg Jan 8 '13 at 17:05
    
# locale LANG=en_US.UTF-8 LC_CTYPE="en_US.UTF-8" LC_NUMERIC="en_US.UTF-8" LC_TIME="en_US.UTF-8" LC_COLLATE="en_US.UTF-8" LC_MONETARY="en_US.UTF-8" LC_MESSAGES="en_US.UTF-8" LC_PAPER="en_US.UTF-8" LC_NAME="en_US.UTF-8" LC_ADDRESS="en_US.UTF-8" LC_TELEPHONE="en_US.UTF-8" LC_MEASUREMENT="en_US.UTF-8" LC_IDENTIFICATION="en_US.UTF-8" –  doon Jan 9 '13 at 20:04
    
The output of the locale command shows that this is a UTF-8 terminal. Is there any other setting I have to do. Thanks for the answers –  doon Jan 9 '13 at 20:05

1 Answer 1

You have two options:

  • configure your ssh client to accept UTF-8 (PuTTY can do this)
  • force 'C' locale: export LC_ALL=C
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.