Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The culprit that do large write to my hard disk has been caught.

It's kjournald

One way to solve the issue is to change the file system to ext2. Is there an easy way to do so?

Another thing that can work is to increase commit time to hard disk.

What does it actually do? If I make commit time 600 seconds will my hard disk fail to write for 600 seconds?

Will it mean less journalling or just delayed journalling?

The data are mostly cache and I don't need perfect accuracy.

We don't have journalling for windows right?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Ext4 mount options

Meta data only journaling(This is default)

data=ordered

To completely disable ext4 journaling(not recommended)

norecovery
noload

To change commit time

commit=<second>

commit has a default and minimum value of 5. Increasing commit value may increase dsik performance but may not reduce journaling amount.

Applying Mount Options

In /etc/fstab, add them to the 4th column separate by comer

#<File Sys>  <Mnt Point> <Type>  <Mount Options>                             <dump> <pass>
/dev/sde1    /home5      auto    auto,noatime,noload,data=ordered,commit=10  0      0

For complete EXT4 mount option : https://www.kernel.org/doc/Documentation/filesystems/ext4.txt

Windows NTFS has journaling. It is more commonly referred as NTFS Log.

share|improve this answer
    
I would have voted for this 10 times. Such detailed answer. –  Jim Thio Jan 9 '13 at 10:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.