Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

aptitude tells me I have some packages with broken dependencies:

kmiller@debian-dev-box:~$ sudo aptitude search '.*' | grep ^.B
iB  console-setup-linux             - Linux specific part of console-setup      
iB  gir1.2-freedesktop              - Introspection data for some FreeDesktop co
iB  gir1.2-glib-2.0                 - Introspection data for GLib, GObject, Gio 
iB  gir1.2-gstreamer-0.10           - Description: GObject introspection data fo
iB  gir1.2-json-1.0                 - GLib JSON manipulation library (introspect
iBA libatk-adaptor                  - AT-SPI 2 toolkit bridge                   
iB  libgcc1                         - GCC support library                       
iBA libgfortran3                    - Runtime library for GNU Fortran applicatio
iBA libgomp1                        - GCC OpenMP (GOMP) support library         
iB  libstdc++6                      - GNU Standard C++ Library v3               

But the 'broken'-ness can't be too bad because:

kmiller@debian-dev-box:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

kmiller@debian-dev-box:~$ sudo apt-get -u dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

It's most worrying that libgcc1 has broken dependencies.

What do I do to find out what to fix?!

kmiller@debian-dev-box:~$ sudo aptitude install -f
...
0 packages upgraded, 11 newly installed, 177 to remove and 0 not upgraded.
...
The following packages have unmet dependencies:
 libstdc++6 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed.
 gir1.2-json-1.0 : Conflicts: gir1.0-json-glib-1.0 but 0.10.2-2squeeze1 is to be installed.
 gir1.2-gstreamer-0.10 : Conflicts: gir1.0-gstreamer-0.10 but 0.10.30-1 is to be installed.
 libgfortran3 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed.
 libgomp1 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed.
 libgcc1 : Breaks: gcc-4.3 (< 4.3.6-1) but 4.3.5-4 is to be installed.
 gir1.2-freedesktop : Conflicts: gir1.0-freedesktop but 0.6.14-1+b1 is to be installed.
 gir1.2-glib-2.0 : Conflicts: gir1.0-glib-2.0 but 0.6.14-1+b1 is to be installed.
 libatk-adaptor : Conflicts: at-spi but 1.32.0-2 is to be installed.
 console-setup-linux : Breaks: console-terminus but 4.30-2 is to be installed.
share|improve this question
    
What about aptitude install -f? –  jordanm Jan 7 '13 at 0:23
    
Hmm good one....aptitude wants to uninstall 177 packages but it does give me some more info –  KarlM Jan 7 '13 at 0:59
    
@jordanm make your comment an answer and I will accept it :) –  KarlM Jan 7 '13 at 1:02

1 Answer 1

up vote 5 down vote accepted

apt-get and aptitude have different dependency resolvers. You can get aptitude to offer suggestions for fixing the broken packages with aptitude install -f. Judging by your updated question, it look like you have mixed releases or distros in your sources.list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.