Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Debian installed on one computer. I just replaced its motherboard and CPU. And graphics card, because I use onboard one. I kept my old hard disk. Now machine boots well, grub starts well, initrd starts well and asks me for a password (because my disk is LUKS encrypted), but then about when it usually changes to framebuffer, monitor goes black and that's all. I guess the hardware is not faulty - I boot knoppix on it and it works well. I guess the problem may be that my initrd does not contain drivers for my new graphics card - can it be the problem? If so, what should I do? The last things which I see on screen before it goes blank is:

INIT: version 2.88 booting
[info] using makefile-style concurrent (...)
[ ok ] Starting the hotplug events (...)
[ ok ] Synthesizing th initial (...)
[....] Waiting for /dev/to be fully (...)
 mmio address 0xfec000f0 already in use

Somebody advised me to pass these parameters to kernel:

nofb vga=normal

So while in grub I chose the entry I use to boot, I pressed "e" to edit it, I found a line starting with linux vmlinuz-3.2.0-3-686-pae root=(...) and at its end I put "nofb vga=normal". Then I pressed F10 to boot, bu it did not help.

Output of hwinfo --gfxcard command is:

29: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_1002_9616
Unique ID: ul7N.IXqEFkX9ypD
Parent ID: vSkL.2yY_xudKZ6E
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: "ATI VGA compatible controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x9616.
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7641.
Driver: "radeon"
Driver Modules: "drm"
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xd000-0xdfff (rw)
Memory Range: 0xfebe0000-0xfebeffff (rw,non-prefetchable)
Memory Range: 0xfea00000-0xfeafffff (rw,non-prefetchable)
IRQ: 18 (16597 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: "pci:v00001002d00009616sv00001462sd00007641bc03sc00i00"
Driver Info #0:
  Driver Status: radeon is active
  Driver Activation Cmd: "modprobe radeon"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)
Primary display adapter: #29

Output of hwinfo --framebuffer command is:

02: None 00.0: 11001 VESA Framebuffer
[Created at bios.464]
Unique ID: rdCR.NSbTZunW9ID
Hardware Class: framebuffer
Model: "(C) 1988-2005, ATI Technologies Inc.  RS880"
Vendor: "(C) 1988-2005, ATI Technologies Inc. "
Device: "RS880"
SubVendor: "ATI ATOMBIOS"
SubDevice:.
Revision: "01.00"
Memory Size: 16 MB
Memory Range: 0xd0000000-0xd0ffffff (rw)
Mode 0x0300: 640x400 (+640), 8 bits
(...)
Config Status: cfg=new, avail=yes, need=no, active=unknown
share|improve this question

migrated from serverfault.com Jan 5 '13 at 12:02

This question came from our site for professional system and network administrators.

add comment

3 Answers 3

You can try to boot passing the kernel option in grub

"vga=normal" 

or

"nofb"

This will disable the use of frambuffer.

To identify you graphic card you can use hwinfo

hwinfo --gfxcard

maybe this can be helpful as well:

hwinfo --framebuffer
share|improve this answer
add comment

Seem that you initrd dont hold the right modules for driving your new motherboard.

Maybe could you

  • boot with rescue debian (on installer disk/key) and ask for a shell terminal in your root partition. If this work, skip following until Rebuild initrd and grub

Else:

  • Boot with a live USB Key (or CDRom)
  • Run a root terminal
  • mount your real / (and /boot) at /mnt

(This sample assume / is on sda5 and /boot on sda1 )

# mount /dev/sda5 /mnt
# mount /dev/sda1 /mnt/boot

bind pseudo fs to /mnt

# for bnd in proc sys dev{,/pts};do mount --bind /$bnd /mnt/$bnd;done
  • run a shell into your system level:

with:

# chroot /mnt
  • Rebuild initrd and grub:

By:

# update-initramfs -k all -u

Maybe following is useless, but

# update-grub

than,

# exit
  • stop bind mounts

simply:

# umount /mnt/{proc,sys,dev{/pts,},boot,}
  • and reboot.

In the hope this will do the job.

# reboot
share|improve this answer
    
Debian, which I have on hard disk, uses 3.0.2 kernel while Knoppix, which I use now, uses 3.6.11 kernel. Isn't it a problem? Will everything work fine if I use 3.6.11 kernel when I create initrd to be used by 3.0.2 kernel? –  user983447 Jan 5 '13 at 16:49
    
Which Debian Is it? Use Original CD which you used to install them, but in rescue mode! –  F. Hauri Jan 5 '13 at 17:23
add comment
up vote 0 down vote accepted

I tried doing update-initramfs, but it did not help. Then I booted debian rescue live cd on my hard disk and installed newest version of kernel (using apt-get install). It helped - now my computer boots well.

Thanks everybody for advices!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.