Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

The question is: I have a laptop, and I extend my desktop on external display, so I get a wide desktop (3200px). When I make the videos on flash fullscreen, don't know why, but the fullscreen appears on my little part of desktop (the laptop display).

Is there any way to tell flash to play fullscreen on my bigger part?

share|improve this question

2 Answers 2

Flash will enter full screen mode on your primary display. In the configuration for your dual monitor set up there should be the option to set the external as the primary display.

share|improve this answer
    
well, it should, but it doesn't =) Tried to switch primary screen in nvidia-settings, but anyway fullscreen appears on the laptop –  M2_ Jan 18 '11 at 12:48

You can change your primary display temporarily with xrandr. I.e. open a terminal and run:

xrandr --output HDMI1 --primary

Where HDMI1 is the RandR output name for your external display. You can determine the name by listing all the outputs with xrandr -q. E.g. in my case, my notebook screen is DP1 and my external LCD (hooked up via DVI) is HDMI1.

Note: If this messes up the relative position of your monitors, you can fix it with something like:

xrandr --output HDMI1 --auto --pos 0x0 --output DP1 --auto --right-of HDMI1

This puts my notebook screen to the right of my external monitor. If your notebook is to the left of your external monitor, change --right-of to --left-of.

To make it permanent, you can run xrandr from a script and stick it somewhere that gets launched automatically (e.g. Startup Applications on Ubuntu).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.