Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to set a larger buffer size in my NIC card. I am following the instruction provide by Intel link, but i think it didn't made any changes.

[root@redhat-enterprise-test01 admin]# rmmod e1000;modprobe e1000
[root@redhat-enterprise-test01 admin]# modprobe e1000 TxDescriptors=4096
[root@redhat-enterprise-test01 admin]# ethtool -g p1p1
Ring parameters for p1p1:
Pre-set maximums:
RX:     4096
RX Mini:    0
RX Jumbo:   0
TX:     4096
Current hardware settings:
RX:     256
RX Mini:    0
RX Jumbo:   0
TX:     256
[root@redhat-enterprise-test01 admin]# ethtool -i p1p1
driver: igb
version: 3.2.10-k
firmware-version: 1.5-1
bus-info: 0000:01:00.0
share|improve this question
2  
Please add more info, and the image directly to the question. See How to Ask? –  mtk Jan 3 '13 at 11:34
    
How about also a copy of /etc/modprobe.conf. –  Karlson Jan 3 '13 at 15:12

1 Answer 1

Create a file i.e e1000.conf in /etc/modprobe.d, put some lines like this,

e1000e RxDescriptors=4096

the unload and reload the e1000e module with, i.e rmmod e1000e; modprobe e1000e

Later verify the parameter with cat /sys/module/e1000e/parameters/RxDescriptors.

This is not tested, my e1000e module is builtin.

EDIT

You could also add the following to /etc/modprobe.conf

options e1000 RxDescriptors=4096 <other options>

This is not the preferred way for newer systems but it is backward compatible depending on the version of RHEL you're running.

share|improve this answer
    
could you see my terminal result now? Am i basically did the same things as you suggested? it doesn't work could it because the name p1p1? –  Bryan Fok Jan 4 '13 at 1:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.