Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try downloading files with Transmission I get:

Error: Permission denied

I've tried searching for this problem, and everyone always says to set permissions correctly, but I've done that:

This is running on a debian headless server and I did have it working until I moved the folders out of my home directory and into one of their own; ever since then I haven't been able to get it up and running, even in my home directory again. I've even purge removed it and installed it again, setting it all up following one of the countless number of guides step for step, and I have gotten nowhere.

I'm not sure if transmission-daemon -f can help you guys to help me, but I thought what it outputs may be relevant because I saw "transmission-daemon requiring authentication":

root@fileserver /# transmission-daemon -f
[19:09:48.940] Transmission 2.03 (11030) started (session.c:622)
[19:09:48.940] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:767)
[19:09:48.940] RPC Server Adding address to whitelist: 192.168.0.* (rpc-server.c:767)
[19:09:48.940] RPC Server Serving RPC and Web requests on port 9091 (rpc-server.c:940)
[19:09:48.940] RPC Server Whitelist enabled (rpc-server.c:944)
[19:09:48.940] RPC Server Password required (rpc-server.c:947)
[19:09:48.940] Port Forwarding Stopped (port-forwarding.c:178)
[19:09:48.940] DHT Generating new id (tr-dht.c:378)
[19:09:48.940] Using settings from "/root/.config/transmission-daemon" (daemon.c:443)
[19:09:48.940] Saved "/root/.config/transmission-daemon/settings.json" (bencode.c:1651)
[19:09:48.940] transmission-daemon requiring authentication (daemon.c:461)
[19:09:48.940] Watching "/home/Transmission" for new .torrent files (daemon.c:473)
[19:09:48.940] Using inotify to watch directory "/home/Transmission" (watch.c:72)
share|improve this question

1 Answer 1

Your permissions aren't right—but its somewhere you're not looking:

It could be on /home/Transmission (you need to make sure it has execute (x) permission on that; ls -ld /home/Transmission to check). As well as on /home, but /home should be a+x already.

Alternatively, it could be on the files themselves—you didn't give an ls -l Transmission/Downloads/.

If you're running SELinux or similar, you may also need to configure that.

Also, are you sure your daemon is running as user debian-transmission? If so, as root:

# su debian-transmission -s /bin/sh -c 'echo test > /home/Transmission/Downloads/testfile'

That should run without error; if you get permission denied, you definitely have a permission problem.

You may also find running strace on the running daemon to be useful. For example, if the daemon is pid 123:

# strace -f -p 123 |& grep EACCES     # yes, acces with one s.

and leaving that running as you add another torrent, or stop/start an existing torrent should quickly find you the permission denied error. It may turn out that its a file you didn't know Transmission was trying to access.

share|improve this answer
    
Wow thanks for that detailed response. Here are the ls outputs: i.imgur.com/zHdCF.png When setting the permissions / ownership, I set them recursively in hopes to avoid this problem. Here is the output from running the echo test: i.imgur.com/1Tp8Z.png So I assume the daemon isn't logging into debian-transmission ? It is set for no password required and hasn't been modified from how it was created during install. Also running the strace command you showed me didn't produce any output: i.imgur.com/IqumP.png –  Lewis Jan 2 '13 at 20:53
    
Well..I'll be damned. I just changed /home from group users to debian-transmission and now all is well...But that doesn't explain how it was working before and then simply moving it from /home/Lewis/Transmission to /home/Transmission does it? Either way, I thank you for the response! –  Lewis Jan 2 '13 at 21:09
    
@Lewis Your permissions on /home are weird; it should have o+x. Instead, has o=r. I'm not sure how they got messed up, but you should chown root:staff /home; chmod 2775 /home (that's the Debian default, drwxrwsr-x). 2771 (drwxrws--x) is another sane value. Your chgrp has probably broken your system, as normal users will not be able to access their files in /home anymore (because they're probably not members of the debian-transmission group) –  derobert Jan 3 '13 at 14:44
    
@Lewis (also, strace should run until you control-C it, for some reason it didn't work. Taking off the |& grep… part should let you see the error, not that it matters anymore) –  derobert Jan 3 '13 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.