Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed squid on my remote linux box and added my desktop's IP as

acl lagrangian64 src XX.XX.XX.XX/32

in squid config.

Also I have added lagrangian64 to the following line:

http_access allow manager localhost lagrangian64

Was this enough and correct?

I am getting and error while browsing any site with this proxy:

ERROR
The requested URL could not be retrieved
While trying to retrieve the URL: http://www.google.com/
...
Access Denied
...

How to allow myself to browse? What I did up for now?

share|improve this question
add comment

2 Answers 2

The line http_access allow manager localhost lagrangian64 allows you to access squid's management interface. All conditions must be matched for a rule to apply - in this case, your IP and localhost (which is impossible) must try to access the manager (which is defined in an earlier acl manager line in the default config file). This should work:

# Allow your IP to everything HTTP
http_access allow lagrangian64
# Allow localhost access
http_access allow localhost
# Deny all other access
http_access deny all

You might also want to comment out some other deny lines, like one limiting the SSL ports.

share|improve this answer
add comment

After configuring settings in squid.conf have you reload squid configuration by doing squid -k reconfigure ? or have you restart squid service ? if possible post your all params in squid.conf grep -Ev "^$|^#" /etc/squid/squid.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.