Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My Linux version is Ubuntu:

> cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

running as virtual machine.

I did as said here

Now when I type

sudo apt-get install google-chrome-stable

I get

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  google-chrome-stable: Depends: libasound2 (> 1.0.22) but 1.0.18-1ubuntu9 is to be installed
                        Depends: libatk1.0-0 (>= 1.29.3) but 1.26.0-0ubuntu2 is to be installed
                        Depends: libc6 (>= 2.11) but 2.9-4ubuntu6.3 is to be installed
                        Depends: libcups2 (>= 1.4.0) but 1.3.9-17ubuntu3.9 is to be installed
                        Depends: libdbus-1-3 (>= 1.2.14) but 1.2.12-0ubuntu2.1 is to be installed
                        Depends: libfontconfig1 (>= 2.8.0) but 2.6.0-1ubuntu12 is to be installed
                        Depends: libgconf2-4 (>= 2.27.0) but 2.26.0-0ubuntu1 is to be installed
                        Depends: libgcrypt11 (>= 1.4.2) but 1.4.1-2ubuntu1 is to be installed
                        Depends: libgtk2.0-0 (>= 2.18.0) but 2.16.1-0ubuntu2 is to be installed
                        Depends: libstdc++6 (>= 4.4.0) but 4.3.3-5ubuntu4 is to be installed
                        Depends: libudev0 (>= 147) but it is not going to be installed
E: Broken packages

What does it mean? Why it doesn't install required packages automatically?

My linux is Linux ubuntu3 2.6.24-19-xen #2 SMP Fri May 23 03:11:08 JST 2008 i686 GNU/Linux

UPDATE

If I use dpkg, I get apparently the same

> sudo dpkg --install google-chrome-stable_current_i386.deb
Selecting previously deselected package google-chrome-stable.
(Reading database ... 31919 files and directories currently installed.)
Unpacking google-chrome-stable (from google-chrome-stable_current_i386.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libasound2 (>> 1.0.22); however:
  Version of libasound2 on system is 1.0.18-1ubuntu9.
 google-chrome-stable depends on libatk1.0-0 (>= 1.29.3); however:
  Version of libatk1.0-0 on system is 1.26.0-0ubuntu2.
 google-chrome-stable depends on libc6 (>= 2.11); however:
  Version of libc6 on system is 2.9-4ubuntu6.3.
 google-chrome-stable depends on libcups2 (>= 1.4.0); however:
  Version of libcups2 on system is 1.3.9-17ubuntu3.9.
 google-chrome-stable depends on libdbus-1-3 (>= 1.2.14); however:
  Version of libdbus-1-3 on system is 1.2.12-0ubuntu2.1.
 google-chrome-stable depends on libfontconfig1 (>= 2.8.0); however:
  Version of libfontconfig1 on system is 2.6.0-1ubuntu12.
 google-chrome-stable depends on libgconf2-4 (>= 2.27.0); however:
  Version of libgconf2-4 on system is 2.26.0-0ubuntu1.
 google-chrome-stable depends on libgcrypt11 (>= 1.4.2); however:
  Version of libgcrypt11 on system is 1.4.1-2ubuntu1.
 google-chrome-stable depends on libgtk2.0-0 (>= 2.18.0); however:
  Version of libgtk2.0-0 on system is 2.16.1-0ubuntu2.
 google-chrome-stable depends on libstdc++6 (>= 4.4.0); however:
  Version of libstdc++6 on system is 4.3.3-5ubuntu4.
 google-chrome-stable depends on libudev0 (>= 147); however:
  Package libudev0 is not installed.
 google-chrome-stable depends on libxss1; however:
  Package libxss1 is not installed.
 google-chrome-stable depends on xdg-utils (>= 1.0.2); however:
  Package xdg-utils is not installed.
dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 google-chrome-stable

UPDATE 2

I don't want to participate in upgrading race. I have many machines and systems and if I would upgrade them all the times they want this, I would spent all my time upgrading. Also after upgrading, many components become uncompilable too.

share|improve this question
4  
Is this Ubuntu 8.04? If so, please try to get a supported version running, this one is unsupported as of 2011-05-12. –  sr_ Jan 2 '13 at 10:52
    
What version of Ubuntu are you running? –  LnxSlck Jan 2 '13 at 17:48
    
Why are you using such an ancient version of Ubuntu? –  Renan Jan 2 '13 at 21:59
add comment

3 Answers

I don't have an official quote to back it up, but from what I've observed, the official Google Chrome packages support all Ubuntu releases for which the desktop version is currently supported. At the moment, this means 10.04, 11.10, 12.04 and 12.10. (8.04 is only supported on servers, and only for a few more months.)

The version requirements correspond to Ubuntu 10.04, e.g. libasound2 is version 1.0.22 in Ubuntu 10.04.

Ubuntu 9.04 stopped being officially supported more than 2 years ago. You should upgrade at least through 9.10 (which is no longer supported but still available from the old releases page to 10.04, and soon to 12.04.

Versions 8.04, 10.04 and 12.04 (basically one every two years) are supported for longer than intermediate relases — they are known as LTS (long-time support) releases.

share|improve this answer
add comment

Your version of Ubuntu is ancient. I doubt a recent version of Google Chrome will run on it.

Just upgrade to a newer version of Ubuntu and Chrome should install smoothly from Google's web site.

share|improve this answer
add comment

There's usually no need to manually add the repository; the Chrome installer does it automatically. It looks like the repository/package you're using depends on software that is only included in later Ubuntu versions. I'd suggest you undo the steps described in the link you posted, then use the Chrome installer.

share|improve this answer
    
How to run your chrome installer from command line? –  Suzan Cioc Jan 2 '13 at 11:37
    
You can just double-click the .deb file, it is then opened & installed by Ubuntu's Software Center. If you want to do it on the commandline, run dpkg --install google-chrome-stable_current_i386.deb –  domsom Jan 2 '13 at 15:55
    
Is there any way to automatically download and install the latest .deb package for Google Chrome? –  Anderson Green Jan 2 '13 at 22:16
    
@AndersonGreen when you install the .deb from Google, it adds Google's repository to apt's repo list. Then Chrome can be updated using the package management. –  Renan Jan 2 '13 at 23:35
    
@Renan I was really asking whether it was possible to download the deb from the command line (instead of via a web browser), and then install it from the command line. Is this possible? –  Anderson Green Jan 2 '13 at 23:45
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.