My Linux version is Ubuntu:
> cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=9.04 DISTRIB_CODENAME=jaunty DISTRIB_DESCRIPTION="Ubuntu 9.04"
running as virtual machine.
I did as said here
Now when I type
sudo apt-get install google-chrome-stable
Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: google-chrome-stable: Depends: libasound2 (> 1.0.22) but 1.0.18-1ubuntu9 is to be installed Depends: libatk1.0-0 (>= 1.29.3) but 1.26.0-0ubuntu2 is to be installed Depends: libc6 (>= 2.11) but 2.9-4ubuntu6.3 is to be installed Depends: libcups2 (>= 1.4.0) but 1.3.9-17ubuntu3.9 is to be installed Depends: libdbus-1-3 (>= 1.2.14) but 1.2.12-0ubuntu2.1 is to be installed Depends: libfontconfig1 (>= 2.8.0) but 2.6.0-1ubuntu12 is to be installed Depends: libgconf2-4 (>= 2.27.0) but 2.26.0-0ubuntu1 is to be installed Depends: libgcrypt11 (>= 1.4.2) but 1.4.1-2ubuntu1 is to be installed Depends: libgtk2.0-0 (>= 2.18.0) but 2.16.1-0ubuntu2 is to be installed Depends: libstdc++6 (>= 4.4.0) but 4.3.3-5ubuntu4 is to be installed Depends: libudev0 (>= 147) but it is not going to be installed E: Broken packages
What does it mean? Why it doesn't install required packages automatically?
My linux is
Linux ubuntu3 2.6.24-19-xen #2 SMP Fri May 23 03:11:08 JST 2008 i686 GNU/Linux
If I use
dpkg, I get apparently the same
> sudo dpkg --install google-chrome-stable_current_i386.deb Selecting previously deselected package google-chrome-stable. (Reading database ... 31919 files and directories currently installed.) Unpacking google-chrome-stable (from google-chrome-stable_current_i386.deb) ... dpkg: dependency problems prevent configuration of google-chrome-stable: google-chrome-stable depends on libasound2 (>> 1.0.22); however: Version of libasound2 on system is 1.0.18-1ubuntu9. google-chrome-stable depends on libatk1.0-0 (>= 1.29.3); however: Version of libatk1.0-0 on system is 1.26.0-0ubuntu2. google-chrome-stable depends on libc6 (>= 2.11); however: Version of libc6 on system is 2.9-4ubuntu6.3. google-chrome-stable depends on libcups2 (>= 1.4.0); however: Version of libcups2 on system is 1.3.9-17ubuntu3.9. google-chrome-stable depends on libdbus-1-3 (>= 1.2.14); however: Version of libdbus-1-3 on system is 1.2.12-0ubuntu2.1. google-chrome-stable depends on libfontconfig1 (>= 2.8.0); however: Version of libfontconfig1 on system is 2.6.0-1ubuntu12. google-chrome-stable depends on libgconf2-4 (>= 2.27.0); however: Version of libgconf2-4 on system is 2.26.0-0ubuntu1. google-chrome-stable depends on libgcrypt11 (>= 1.4.2); however: Version of libgcrypt11 on system is 1.4.1-2ubuntu1. google-chrome-stable depends on libgtk2.0-0 (>= 2.18.0); however: Version of libgtk2.0-0 on system is 2.16.1-0ubuntu2. google-chrome-stable depends on libstdc++6 (>= 4.4.0); however: Version of libstdc++6 on system is 4.3.3-5ubuntu4. google-chrome-stable depends on libudev0 (>= 147); however: Package libudev0 is not installed. google-chrome-stable depends on libxss1; however: Package libxss1 is not installed. google-chrome-stable depends on xdg-utils (>= 1.0.2); however: Package xdg-utils is not installed. dpkg: error processing google-chrome-stable (--install): dependency problems - leaving unconfigured Processing triggers for menu ... Processing triggers for man-db ... Errors were encountered while processing: google-chrome-stable
I don't want to participate in upgrading race. I have many machines and systems and if I would upgrade them all the times they want this, I would spent all my time upgrading. Also after upgrading, many components become uncompilable too.