Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I downloaded a .pem file and my Mac OS X (10.8.2) added an @ sign at the end of the file permissions. This is causing file permission issues. I can't seem to remove the quarantine flag. I even tried the command

xattr -d <filename>.pem 

but that didn't work

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

xattr -d requires you to specify which attribute you want to remove. You can find this out by listing the file attributes by passing ls the -@ flag as in:

ls -l@ filename

Once you know what the attribute is, you can target it for removal with -d or you can use the following to clear all attributes:

xattr -c filename
share|improve this answer
    
Sweet. That worked. Thanks!! –  Das Jan 2 '13 at 4:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.