Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since a few months I have been facing a problem with Fedora 15. Whenever I start my system, the command prompt is displayed instead of the GUI login. I need to provide a username and password from the command line every time, and after that I have to run startx.

Whats wrong with my system? Is there any missing file or configuration? How do I fix this problem?

Do i need to reinstall my system to solve this problem?

Any help and idea will be appreciated.

share|improve this question
    
Is a display manager like gdm or kdm installed? – jofel Dec 31 '12 at 10:33
    
yeah kdm is installed in my system. but /run/kdm/ directory seems empty. – juned Dec 31 '12 at 10:38
    
did you change by any change the /etc/inittab? it should have a entry with the default run-level, which should be 5. also, check on you chkconfig if you have the gdm/kdm starting – BitsOfNix Dec 31 '12 at 13:21
    
Nope,i didn't change anything in /etc/inittab/ and i checked i that file which contains nothing.and yeah i checked gdm or kdm is not started. – juned Dec 31 '12 at 13:42
2  
Type runlevel into the command prompt and post what it says. – cpast Dec 31 '12 at 15:33

I had a similar problem with Fedora 24. Although as it uses systemd, the solution may not apply to Fedora 15.

For a systemd + kde system, first see if kdm service is disabled.

systemctl status kdm.service

If it's the case, simply enable it.

systemctl enable kdm.service

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.