Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed Arch in my PC alongside windows 7 but for some reason it boots directly into the rescue shell, this is how it looks

It doesn't show any errors though, and if I press Ctrl+D it just shows me my display manager like normal, how can I make it so it boots directly into the display manager? Thanks in advance.

share|improve this question
    
Try rerun mkinitcpio -p linux. –  uzsolt Dec 30 '12 at 15:27
    
Thanks I just tried it but no luck, maybe I enabled it in the boot options by mistake? I'm not sure what can I post to help debugging it –  javiervd Dec 30 '12 at 15:57
    
Please check this: wiki.archlinux.org/index.php/Mkinitcpio#Using_LVM - and of course the full article :) I think it will help you :) –  uzsolt Dec 30 '12 at 19:47

1 Answer 1

up vote 0 down vote accepted

Got it to work I just had to change this:

root=/dev/mapper/vgroup-arch--root cryptdevice=/dev/sda6:vgroup ro rootfstype=ext4 systemd.unit=graphic.target

To this:

root=/dev/mapper/vgroup-arch--root cryptdevice=/dev/sda6:vgroup ro rootfstype=ext4

In my bootloader options.

share|improve this answer
    
You should accept this as the answer to your question. –  paraxor May 1 '13 at 20:26
    
I forgot about this, thanks –  javiervd May 1 '13 at 20:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.