Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Right now I'm using OpenSUSE 12.2 with KDE 4.9.4. If I upgrade that to KDE 4.10 in January, will it also bring in Qt 5 (or at least newer Qt packages)? Or are the Qt packages tied to the OS?

share|improve this question
3  
KDE 4.10 does not require QT5 and it needs Qt (>= 4.7) and kdelibs (4.8) development packages.so mostly it won't be updated and KDE5 will be using QT5 it seems. –  harish.venkat Dec 29 '12 at 18:47
    
@harish.venkat OK, thank you. That answers my question. –  PrinceBilliard Dec 30 '12 at 3:07
add comment

1 Answer

Just to add a little detail: OpenSUSE 12.2 is using libQt 4.8.1, while Tumbleweed and Factory (12.3) are using libQt 4.8.4. There will be no need to perform a major version upgrade to Qt5 in the foreseeable future. Equally, as harish provided; KDE4.10 does not require Qt5; so if you are running an installation of openSUSE Factory (which will receive Qt5 first) - you can hold back the packages by using Zypper's lock commands.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.