Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have two NICs assigned to a server.

eth0 - 10.199.10.0/24 w/ a GW of 10.199.10.1
eth1 - 10.199.20.0/24 w/ a GW of 10.199.20.1

From my desktop, I can ping the IP assigned to each NIC just fine (10.199.10.100 and 10.199.20.100). So I set up Apache to listen on ALL ips on said server. I tested this just fine from my desktop as well. Now, I went to create a new VM on the 10.199.20.0 subnet and I can access the RH test page by hitting http://10.199.20.100 BUT I can't access it via 10.199.10.100.

This is troublesome since I have a bunch of services on this server that can only listen on one particular IP (the 10.199.10.100). My network guy tells me the routes look fine and that it could be the routing table on the server itself.

#ip route
10.199.10.0/24 dev eth0  proto kernel  scope link src 10.199.10.100
10.199.20.0/24 dev eth1  proto kernel  scope link src 10.199.20.100
169.254.0.0/16 dev eth0  scope link  metric 1002
169.254.0.0/16 dev eth1  scope link  metric 1003
default via 10.199.10.1 dev eth0

# ip rule
0:      from all lookup local
32764:  from all to 10.199.20.100 lookup build
32765:  from 10.199.20.100 lookup build
32766:  from all lookup main
32767:  from all lookup default

Netowrk Layout

These servers are Xen guests. We have four Xen servers with multiple NICs. The admin server with the two NICs have two virtual NICs assigned to them. One from 10.199.10.x and one from the 10.199.20.x subnet (two different NICs). The test server only has the 10.199.20.x network assigned to it. I can ping the 10.199.30.x network just fine.

share|improve this question
    
What does netstat -tln|grep -w 80 show? –  Nils Dec 28 '12 at 22:21
    
VM? What VM - please explain that bit (especially the network setup of your VM in relation to your server). –  Nils Dec 28 '12 at 22:23
    
see edits above. netstat shows 0.0.0.0:80 I can hit both IPs via Apache from my desktop just fine. –  luckytaxi Dec 28 '12 at 22:38
    
(1) Does your desktop has IP(s) for both subnet? (2) Where is the VM residing? (in your desktop machine?) (3) Please post following: From desktop and from VM (3a) traceroute 10.199.10.100 (3b) traceroute 10.199.20.100. Potential solution: (4a) Add one more interface to your VM, assign a 10.199.20.x IP to it, (4b) Add 10.199.20.x IP to existing VM nic. If that works I will move this to answer. –  John Siu Dec 29 '12 at 0:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.