Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I have installed a minimal installation of CentOS 6.3 inside a VirtualBox VM. Now, I would like to install Emacs for use from the command line only.

When I do a search for emacs using yum search emacs the only application level package seems to be "emacs" so I run yum install emacs and it shows me the list of dependencies it wants to download.

These dependencies libcairo, libasound, and a ton of libX* packages that have no business being downloaded and installed for a copy of Emacs that will be used from the command line only (I am trying to keep this minimal since this will be cloned 10 times per developer machine for network simulation but a text editor really is necessary).

So, are there some flags to set to prevent all the graphical related packages from installing? I remember Gentoo's emerge had paremeters like that, or am I just installing the wrong package?

share|improve this question

3 Answers 3

No. There is emacs-nox on CentOS and Fedora.

$ sudo yum -y install emacs-nox
share|improve this answer

I loath the GUI. Try this:

Download the latest tar:

## extract it *24.5 is the current.    
$ tar -xvf emacs-24.5.tar.xz

## get emacs dep libs.
$ sudo apt-get build-dep emacs24

## mv to extracted dir.     
$ ./configure --with-x=no

## build.
$ make

## mv binaries system wide.    
$ make install
share|improve this answer
Why did this get downvoted with no comments? Is there something wrong with this? This was exactly what I needed for installing to a headless CentOS server. Before using ./configure --with-x=no I kept getting emacs: error while loading shared libraries: cannot open shared object file: No such file or directory. I knew I did not need gtk-3 for a headless installation and after using this, it ran without any problems. When I used sudo yum -y install emacs-nox I got No package emacs-nox available Error: Nothing to do. – stvn66 Jun 26 at 23:32
Probably downvoted because apt-get is not yum. The answer is otherwise ok. – chriskelly Oct 18 at 13:41

I follow these steps to install Emacs on my cloud Ubuntu server without X support:

  1. sudo apt-get install autoconf automake texinfo libncurses5-dev
  2. ./
  3. ./configure --with-x=no
  4. make
  5. sudo make install

And now you can use Emacs in the terminal.

autoconf and automake are the required system tools.

If you miss texinfo, you'll get:

configure: error: You do not seem to have makeinfo >= 4.7, and your source tree does not seem to have pre-built manuals in the 'info' directory. Either install a suitable version of makeinfo, or re-run configure with the '--without-makeinfo' option to build without the manuals.

If you miss libncurses5-dev, you'll get:

configure: error: The required function 'tputs' was not found in any library. The following libraries were tried (in order): libtinfo, libncurses, libterminfo, libtermcap, libcurses Please try installing whichever of these libraries is most appropriate for your system, together with its header files. For example, a libncurses-dev(el) or similar package.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.