Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I' ve just installed Arch Linux on my computer, I have some problems: If I write

# iwconfig

The result is

-bash: iwconfig: command not found

the same is with ifconfig instead if I try with

# wifi-menu

I have

Please install 'dialog' to use wifi-menu

I don't have a modem to connect wire. What should I do?

share|improve this question
I' ve solved using a ethernet wire and writing dhcpcd than I tried to ping ping -c 3 www.google.it And I saw that now I'm connected ;) – AlessioMTX Dec 27 '12 at 15:17
Now I' m again disconnetted and I don' t know why, iwconfig still doesn't work – AlessioMTX Dec 27 '12 at 15:24
After dialog install the connection is fallen downl EDIT: MY ETH WIRE IS BROKEN -.-" but iwconfig?? – AlessioMTX Dec 27 '12 at 15:25
up vote 2 down vote accepted

iwconfig is part of the wireless_tools package, and ifconfig is part of net-tools on my Arch laptop (relatively up-to-date). To install:

pacman -S wireless_tools  net-tools

It sounds like you need to educate yourself on the use of systemctl to start/stop the DHCP client service. My first guess after "bad cable" would be that dhcpcd isn't working correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.