Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used the Universal USB Installer application to copy the latest ISO image from Linux Mint DE (64 bits) and install it on my PC, however when I try to reboot it I have the option to choose my connected USB device as "UEFI: ... USB ..." but when I choose it it doesn't do anything, the screen goes black for a couple seconds then loads windows 7 normally.

Should I do something before trying to boot into the USB device? This is my first time trying to install a linux distro on a UEFI-based PC I never had a problem like this before. Thanks in advance.

share|improve this question
    
This does not address you particular problem, but might be helpful: Information about how to set up Debian on UEFI –  Marco Dec 26 '12 at 23:18
    
I see, so maybe I need a .efi file in the USB to be able to boot it? I was browsing the files and there's no EFI folder or anything like that –  javiervd Dec 27 '12 at 0:45
    
No you don't need any .efi, read my answer below... –  YoMismo 7 hours ago

3 Answers 3

I believe you did not mount your ISO to your USB. You can use something like UNetbootin to mount it. Shouldn't be a problem.

share|improve this answer
    
I did but I had the same problem, Universal USB Installer works pretty much the same anyways –  javiervd Dec 27 '12 at 2:08
    
Oh, forgive my ignorance. Have you tried (Care to try?) other versions of Linux Mint? –  elwc Dec 27 '12 at 2:39
    
No worries, I tried the regular version 14 but same outcome.. –  javiervd Dec 27 '12 at 4:03

I've had issues where unetbootin didn't set the correct volume label; some distributions expect to be able to mount the volume by volume label.

I've gotten around this by using the dd utility to copy the entire filesystem from the .iso to the USB drive.

For example, if the USB is at /dev/sdc and your Linux Mint installation image is at /home/me/mint.iso:

dd bs=4m if=/home/me/mint.iso of=/dev/sdc

The of argument tells it the output file to write to, so make sure you point it at the right drive - and make sure you point it at the volume itself, not a partition like /dev/sdc1.

I've personally booted from Linux isos on EFI systems using this method and it's been fine.

share|improve this answer
    
Sounds good, however since I haven't been able to install or even boot the live cd of any linux distro due to this uefi problem I can't use the dd command (currently on win7) do you have any idea how I should do it? –  javiervd Dec 27 '12 at 4:05
    
Nvm, I was able to boot a live usb image of ubuntu 12.10 and tried your suggestion, still the problem persists :( –  javiervd Dec 27 '12 at 4:34

You should do a couple of changes in your BIOS. First you should disable boot safe, look for it in your BIOS, then you should activate CSM to let all the boot devices be visible (at least in my asus x550c) then disable fast boot. I think with those changes you should be ready to go. Wipe your F*?-ng Windows and install that linux distro you are willing to install.

In case you want to keep your windows, I think you will have to do a couple more changes otherwise your grub won't boot, but I didn't get that far, I just wiped all windows 8.x partitions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.