Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This was really wired! All = became q on my xfce4-terminal app, what's wrong with it?

Any ideas?

enter image description here

%> set | grep LANG
LANG=en_US.utf8
LANGUAGE=en_US.utf8
share|improve this question
    
What does set | grep LANG say? –  jippie Dec 25 '12 at 12:42
    
@jippie updated –  warl0ck Dec 25 '12 at 13:10
    
Does it happen only in xfce4-terminal or on other X terminal emulators as well? –  peterph Dec 25 '12 at 21:32
add comment

1 Answer 1

I assume this only happens in ncmpcpp. Does your build of ncmpcpp support charset detection? See output of ncmpcpp --version. If this is not the case, try setting the following option in ~/.ncmpcpp/config:

system_encoding = <your_encoding_here>

And in ~/.mpdconf:

filesystem_charset "<your_encoding_here>"

Also make sure your xfce4-terminal matches this same encoding.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.