Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Noticed from my previous question that when trying to copy an SSH public key to a remote host via ssh-copy-id, I am prompted for the local user password three times:

ssh-copy-id myuser@myserver
Password:
Password:
Password:
myuser@myserver's password:

Why am I being prompted three times for the local user's password? Is that an expected behavior? Also, what is going on under the hood??

EDIT: when using ssh, it doesn't prompt for the local user password.. And my local password is an ordinary Linux password of my laptop, and the remote machine is an Ubuntu box (11.10) joined to an Active Directory Domain via likewise-open. So myuser is actually mydomain\myuser or myuser@mydomain.com, escaping the \ character as in my previous question.. The remote machine /etc/ssh/sshd_config file is as follows:

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
#Overwritten by lwidentity: ChallengeResponseAuthentication no
ChallengeResponseAuthentication yes

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes
KbdInteractiveAuthentication yes
share|improve this question
    
What is your current ssh_config/~/.ssh/config? Which platform are you on? –  gertvdijk Dec 20 '12 at 13:30
    
@gertvdijk .ssh folder contains no config file. I'm on Ubuntu 12.04, and OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012 –  amyassin Dec 20 '12 at 16:31
    
ssh-copy-id does not do anything that requires authentication other than calling ssh. Do you get the same prompt if you run ssh? Is this your local password or a network (LDAP?) password? (If your local password is obtained from LDAP, you can't tell.) It's possible that SSH is using a federated authentication mechanism such as Kerberos. What is in /etc/sshd_config or /etc/ssh/sshd_config on the server? –  Gilles Dec 21 '12 at 1:00
    
@Gilles no, ssh does not prompt for the local user's password. It only prompts for the remote machine's password.. It is a local linux machine password, a local user of my laptop.. I updated the question, too.. –  amyassin Dec 25 '12 at 7:11
    
I can only think of three other reasons now. 1) your ssh-copy-id is altered/different, or 2) you've aliased it to something you didn't want it to, or 3) your ssh-agent only releases public keys after giving the private key password for some odd reason. –  gertvdijk Dec 25 '12 at 9:19

1 Answer 1

ssh-copy-id is just a wrapper shell script performing these steps:

  1. Find the public key(s), this includes talking to the SSH agent for which keys it has available.
  2. log in to the remote server like any other SSH client
  3. copy one or more public keys to the remote server in a file .ssh/authorized_keys, including creating the directory if it does not exist with the right permissions.

You can see for yourself what it is doing by reading the /usr/bin/ssh-copy-id. Copy over the file, add some debugging to the code to see what happens and what the values of variables are during the execution.

share|improve this answer
    
So it doesn't need the local user's password I guess?? Nothing requires it in that procedure, unless finding the public key does? –  amyassin Dec 20 '12 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.