Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to get a samba to work with a windows AD. And i can't use my shares through samba.

My smb.conf

#GLOBAL PARAMETERS
[global]
   workgroup = MY_DOMAIN
   realm = MY_DOMAIN.COM
   preferred master = no
   server string = Linux Test Machine
   security = ADS
   encrypt passwords = yes
   password server = MY_MASTER_DOMAIN_CONTROLLER
   log level = 3
   log file = /var/log/samba/%m
   max log size = 50
   printcap name = cups
   printing = cups
   winbind enum users = Yes
   winbind enum groups = Yes
   winbind use default domain = Yes
   winbind nested groups = Yes
   winbind separator = +
   idmap uid = 1100-20000
   idmap gid = 1100-20000
   ;template primary group = "Domain Users"
   template shell = /bin/bash



[homes]
   comment = Home Direcotries
   valid users = %S
   read only = No
   browseable = No

[tmp]
   comment = Directory for storing pictures by jims users
   path= /var/tmp
   Valid Users = @"MY_DOMAIN+group name" MY_DOMAIN+MY_ACCOUNT
  ; public=no
   writable=yes
   browseable=yes
   read only = no
   guest ok = no
   create mask = 0777
   directory mask = 0777

wbinfo -u and wbinfo -g work as expected. kinit MY_ACCOUNT@MY_DOMAIN.COM works too.

But i can't connect to samba. I'm using debian 5, samba 3.2.5 and kerberos 5. My /var/www is 777. Any ideas ?

UPDATE :

testparm ==>

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[tmp]"
Loaded services file OK.
'winbind separator = +' might cause problems with group membership.
Server role: ROLE_DOMAIN_MEMBER

UPDATE 2 :

I'm able to connect on linux with my AD credentials, but samba don't want to let me access to my shares with the same credentials.

share|improve this question
    
have you checked testparams ? –  Rahul Patil Dec 17 '12 at 14:48
    
Yeah. Post updated. –  Perello Dec 17 '12 at 14:58
    
You cannot access [tmp] or [homes] or both? –  John Siu Dec 18 '12 at 3:34

2 Answers 2

When you login, did you try with the following:

DOMAINAME\username 

as your username? Also, try checking the permission settings of your /usr/tmp and your home directories.

Also, you might want to set the path to the home directories, mine is setup as such:

path = /home/%S
valid users = %D+%S

Even with "winbind use default domain = Yes", I still had to login with my domain name..

Edit: I am using Samba version 3.5.10. Not sure if it matters.

share|improve this answer
up vote 0 down vote accepted

Ok, it doesn't work from my windows, for an unknown reason. But it does work from a linux and from 2 another windows 7. So the conf file i gave is right.

Edit :

This is indeed an answer, because the samba/kerberos was working. The problem came from my windows, it had a wrong (old) login/pwd (linked to my linux server) saved in the secured password location. It seems windows was sending these old credentials and not the one i typed.

We got the same problem on 2 or 3 computers. Everything worked once we removed it.

share|improve this answer
    
This is not an answer. You can edit your question to add additional information. –  Marco Dec 17 '12 at 17:35
    
is your windows machine is part of your domain ? –  Rahul Patil Dec 18 '12 at 8:13
    
have you checked any errors in smb logs ? –  Rahul Patil Dec 18 '12 at 8:15
    
@Marco, indeed it was an answer, at least to the samba problem. Because samba was perfectly functional. I have edited my answer. –  Perello Jan 2 '13 at 15:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.