Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

When using a tty login shell by entering Ctrl-Alt-F1 from an Ubuntu 12.04 install on a laptop the keyboard seems overly sensitive and if my finger lingers for a moment on a button I end up with repeats of the same letter. Is there a way to adjust keyboard sensitivity that would influence the keyboard response when accessing a login shell from a tty instance?

share|improve this question

2 Answers 2

up vote 10 down vote accepted

It is called 'keyboard auto repeat rate' and you can set it with kbdrate Mine is set to:

$ sudo kbdrate
Typematic Rate set to 10.9 cps (delay = 250 ms)

You can set same with:

$ sudo kbdrate -r 10.9 -d 250
Typematic Rate set to 10.9 cps (delay = 250 ms)

Check the manual page for exact options:

man kbdrate

Unsure where the default setting is done, but /etc/rc.local, your .bash_profile, .profile or .bashrc sounds like a good place.

share|improve this answer

(I noticed a complaint that kbdrate might have a max limitation. Not sure how true it still is).

I use xset r rate 250 60 to accomplish speedups to my liking. I happen to put that in my ~/.i3/config (for i3wm) but I used to have it working in my ~/.xinitrc for startx to pick up. The xset invocation should apply to everything running in X.

(I’d be curious to hear if there’s any reason to prefer kbdrate or xset.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.