Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I boot, I get the error message waiting for network configuration, then waiting an additional 60 seconds for network configuration.

I had edited /etc/network/interfaces file before the above message, so as to surf through a friend's laptop using Ethernet cable; then, after restoring the file, I still get the same message. I have searched in the internet but I didn't find anything helpful.

The content of /etc/network/interfaces is:

auto lo
iface lo inet loopback

What is wrong?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Your configurations seem fine. Check if you saved the file after editing, if not

sudo nano /etc/network/interfaces if you are using nano

sudo vim /etc/network/interfaces if you use vim the remove whatever is there and replace with the following auto lo iface lo inet loopback

reboot now, and you should be ok :)

share|improve this answer
    
Thanks a lot. Worked like charm! –  Alex Kasina Dec 16 '12 at 8:12
add comment

You are missing eth0 section, try adding the following

auto eth0
iface eth0 inet dhcp

Then reboot.

share|improve this answer
2  
Linux is different from Windows. Just do ifup eth0 after editing, maybe a ifdown eth0 before. –  ott-- Dec 15 '12 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.