Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Debian Wheezy, I'm trying to install the vmware-view-client package from the Ubuntu Software Center (because the open client won't work for my situation), but dpkg can't handle it. Synaptic says I have libssl1.0.0 installed (1.0.1c-4, along with -dev and -doc), but I get the following error message:

$ dpkg -i vmware-view-client_1.6.0-0ubuntu0.13.04_i386.deb 
(Reading database ... 154107 files and directories currently installed.)
Preparing to replace vmware-view-client 1.6.0-0ubuntu0.13.04 (using vmware-view-client_1.6.0-0ubuntu0.13.04_i386.deb) ...
Unpacking replacement vmware-view-client ...
dpkg: dependency problems prevent configuration of vmware-view-client:
 vmware-view-client depends on libssl0.9.8 (>= 0.9.8m-1); however:
  Package libssl0.9.8 is not installed.

dpkg: error processing vmware-view-client (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:

Do I need to somehow get an earlier version of libssl (if so, how?) or can I somehow convince dpkg to use my version of libssl anyways?

share|improve this question
up vote 2 down vote accepted

0.9.8 is the ABI version (aka soversion), so, yes, you need to install the older version. The 0.9.8 and 1.0 ABIs are not compatible.

I'd suggest installing libssl0.9.8 in the normal manner, e.g., using the GUI or aptitude install libssl0.9.8. 0.9.8 is available in both 12.04 and 12.10 according to http://packages.ubuntu.com/

Then you should be able to install the vmware client.

share|improve this answer
Thanks! I got it from packages.debian.org/squeeze/i386/libssl0.9.8/download instead, but it worked! – Nate Parsons Dec 14 '12 at 17:10
@NateParsons You should get it from your repository (Ubuntu in your case) to get security updates and not break upgrades. There's no reason for installing from other sources if your distribution provides it. – gertvdijk Dec 14 '12 at 17:20
But I'm not running Ubuntu, I was just using its repository because VMWare doesn't provide any other way to download their debs. – Nate Parsons Dec 18 '12 at 19:33
@NateParsons ah, if you're actually running Debian, you should have said so. We all assumed Ubuntu because you mentioned the Ubuntu Software Center. And that aptitude line should work on Debian, too. – derobert Dec 18 '12 at 20:53
Whoops, I thought I had. Question updated. It's configured with aptitude now. – Nate Parsons Dec 18 '12 at 21:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.