Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Fresh Install of FreeBSD 9 and KDE 4. System boots to KDE log in screen, but no mouse or keyboard when I get there. I can CtrlAltF1 out of the KDE.

I Have the following lines in rc.conf:

Option "AutoAddDevices" "false"
local_startup="$(local_start_up) /usr/local/kde4/etc/rc.d"
share|improve this question

This line,

Option "AutoAddDevices" "false"

is certainly not meant for rc.conf but for xorg.conf (from man xorg.conf):

Option "AutoAddDevices" "boolean"

If this option is disabled, then no devices will be added from the HAL or udev backends. Enabled by default.

Just try to add it there (to the ServerLayout or ServerFlags section, see the documentation on X11 Configuration).

I'm a little surprised you got KDM started at all, I'd have expected things below the line-not-meant-for-rc.conf to be ignored.

share|improve this answer

I was stuck with the same issue some minutes ago. After many unsuccessful queries using search engines, I checked the log to try to understand why those input methods weren't working.

In my case, installing the following 2 ports solved. I hope that it can help you out.

cd /usr/ports/x11-drivers/xf86-input-keyboard && sudo make install clean
cd /usr/ports/x11-drivers/xf86-input-mouse && sudo make install clean

After installing those, I rebooted my FreeBSD box and was able to get through the gdm login window.

[ PS: same answer as given in http://superuser.com/a/582666/192509, since it is a similar issue from my point of view. ]

share|improve this answer
I had to use make reinstall because the same version was already installed(but badly). – JaDogg Oct 6 '14 at 21:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.