Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Arch with 3.6.10 kernel,

When vboxpci module is loaded, it tells me vboxpci: IOMMU not found (not registered),

But I checked my kernel config, I have the INTEL_IOMMU set already (I uses a Thinkpad X220)

CONFIG_GART_IOMMU=y
# CONFIG_CALGARY_IOMMU is not set
CONFIG_IOMMU_HELPER=y
CONFIG_IOMMU_API=y
CONFIG_IOMMU_SUPPORT=y
# CONFIG_AMD_IOMMU is not set
CONFIG_INTEL_IOMMU=y
CONFIG_INTEL_IOMMU_DEFAULT_ON=y
CONFIG_INTEL_IOMMU_FLOPPY_WA=y
# CONFIG_IOMMU_STRESS is not set

Kernel command:

BOOT_IMAGE=/boot/vmlinuz-linux root=/XX processor.ignore_ppc=1 apparmor=1 security=apparmor intel_iommu=on

Any suggestions? Althrough VBox starts, but still wondering why.

share|improve this question
    
What does dmesg | grep -i iommu show? In my case VT-d as it's called was disabled in the BIOS on some machine. –  gertvdijk Dec 12 '12 at 15:34
    
@gertvdijk Nothing but kernel cmd line; Looks like i5 2450m doesn't have VT-d feature –  warl0ck Dec 12 '12 at 15:43
    
Indeed. Intel ARK page confirms it. You'll have to live without this feature. –  gertvdijk Dec 12 '12 at 15:46
    
I have bad experience with hardware IOMMU (which doesn't mean it's a bad technology, it just means that it didn't work on my systems). I always switch it off. See my comments: Enabling IOMMU in the kernel for graphics card pass-through –  Marco Dec 12 '12 at 17:26
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.