Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm triple booting osx, win 7 and arch on an apple macbook pro 8,2

I've followed the guide specific for my macbook pro here: Macbook Pro 8,2 Arch Installation

As well as the beginners install guide here: Arch Beginners Guide

Everything has gone well and I can boot and login fine.

However I've come to a problem whilst trying to configure grub2.

I've run this and I've verified that its worked correctly

# modprobe dm-mod 
# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --boot-directory=/boot/efi/EFI --recheck --debug
# mkdir -p /boot/efi/EFI/grub/locale
# cp /usr/share/locale/en\@quot/LC_MESSAGES/grub.mo /boot/efi/EFI/grub/locale/en.mo

However when I run,

# grub-mkconfig -o /boot/efi/EFI/grub/grub.cfg

Whilst the config generator is running it spits out text from os-prober. It lists my osx and Windows partition but nothing about Arch.

The config file generated doesn't contain any information about Arch either and when I try boot into grub2, it lists 2 Mac OSX partitions, 32 and 64 bit (of which only 1 exists) and neither boot as well as a Windows 7 partition which doesn't boot either.

I think a big part of the problem is that os-prober isn't detecting the installations correctly. Does anyone have any idea why this would be?

Thanks,

Alex

share|improve this question
1  
file $(which os-prober) reveals it's a shell script; so maybe you can have a look inside –  sr_ Dec 11 '12 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.