Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

As the title says, I'm having trouble with a very noisy audio input device - the internal mic or any plugged in mics.

So far I've narrowed it down to an problem in ALSA since my debug info is showing a lot of "null" values. Can anyone help?

Debug Info: http://www.alsa-project.org/db/?f=e0c6fb7e10624bf7691aa2b405cf0d3968e56c63

Exert from the debug:

model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)

Using Ubuntu 12.04 (x86_64)...

share|improve this question

1 Answer 1

The (null)s have nothing to do with this.

Try increasing the Capture volume instead of the Mic Boost.

However, it's possible that your analog input just is that bad. Do you get better quality in Windows?

share|improve this answer
    
Thanks for your answer. I tried using all sorts of configurations in alsamixer... non helped at all. Yes I do get better quality in Windows (much better!). Thought I'd see if it was just my internal mic, or not... so I went and grabbed out my old webcam w/ mic (MS LifeCam HD) - which had excellent audio quality on my desktop back in Ubuntu 10.04 when I use to use it. Same problem occurs! Too much noise... the audio quality is better, but there's just too much background "white" noise. –  hazrpg Dec 8 '12 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.