Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been seeing machine check exceptions when trying to call dahdi_cfg (or, sometimes, even on just loading the kernel module) to configure a Digium Wildcard TE420 Quad-Span T1 PCI-E card. Running Debian Wheezy (kernel 3.2.0-4), dahdi kernel modules 2.6.1.

Machine check looks something like this (recovered using netconsole; machine is quite dead after MCE):

CPU 1: Machine Check Exception: 5 Bank 5: b200121020080400
RIP !INEXACT! 10:<ffffffff810146a3> {mwait_idle+0x7f/0xac}
TSC b773cee10f 
PROCESSOR 0:6f7 TIME 1354843514 SOCKET 0 APIC 1 microcode 66
Run the above through 'mcelog --ascii'
CPU 1: Machine Check Exception: 5 Bank 0: b200004000000800
RIP !INEXACT! 10:<ffffffff810146a3> {mwait_idle+0x7f/0xac}
TSC b773cee10f 
PROCESSOR 0:6f7 TIME 1354843514 SOCKET 0 APIC 1 microcode 66
Run the above through 'mcelog --ascii'
Some CPUs didn't answer in synchronization
Machine check: Processor context corrupt
Kernel panic - not syncing: Fatal machine check on current CPU

By fiddling around with which PCI express socket its plugged into, as well as removing the other PCI-E card (an nVidia video card), sometimes it doesn't immediately machine check. I then managed to get an error in the kernel log. I get these messages, error is the last line:

[    6.222755] wct4xxp 0000:02:08.0: 5th gen card with initial latency of 2 and 1 ms per IRQ
[    6.222767] wct4xxp 0000:02:08.0: Firmware Version: c01a016d
[    6.225338] wct4xxp 0000:02:08.0: FALC Framer Version: 3.1
[    6.225477] wct4xxp 0000:02:08.0: Found a Wildcard: Wildcard TE420 (5th Gen)
[    6.225525] wct4xxp 0000:02:08.0: VPM450: Not Present
[   13.089474] wct4xxp 0000:02:08.0: Span 1 configured for ESF/B8ZS
[   13.089616] wct4xxp 0000:02:08.0: RCLK source set to span 1
[   13.089621] wct4xxp 0000:02:08.0: Recovered timing mode, RCLK set to span 1
[   13.089627] wct4xxp 0000:02:08.0: SPAN 1: Primary Sync Source
[   15.192016] wct4xxp 0000:02:08.0: Interrupts not detected.

Checking /proc/interrupts indeed confirms that the 1000-per-second expected interrupts aren't present. Also, alarm lights (there are currently no T1s plugged in) aren't on; there are no lights lit on the board.

Googling didn't find much useful. There is a patch to the dahdi drivers, but that should already be included in the version I'm using. Someone else had this problem with an old revision of the board (solved by getting a newer board), but I have the newer revision. I unfortunately do not have a spare machine to check on.

share|improve this question
I've put this question and answer here because I didn't find any suggestion to try a BIOS upgrade from quite a bit of Googling, and, really, how often do BIOS upgrades help? Hopefully it'll be useful to anyone else who runs across odd MCEs. – derobert Dec 7 '12 at 18:37
up vote 3 down vote accepted

Turns out the fix was fairly simple—a BIOS upgrade. Upgrading from 0801 to 1406 (the most recent as of this writing, from 2009) fixed it.

Direct link to the 1406 BIOS update. Or the P5N-E SLI download page should have the latest.

share|improve this answer
How did you figure that out? – Tim Jan 30 '13 at 17:54
@Tim Its been a bit, but I think it was basically banging my head against the wall and asking "what else is there left to try...". Wasn't any reason to expect it to work, really. Isn't really anything in the BIOS release notes. – derobert Jan 30 '13 at 20:25
@Tim there was also a lot of other hardware troubleshooting I did, like pulling memory modules, etc. I think there were some weird memory issues, and one of the release notes does mention improved memory compatibility, so maybe that's why I tried. – derobert Jan 30 '13 at 20:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.