Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I don't know how to stop compiz from animating the drop-down list from chromium browser, it only appears if you type something, and disappears when focus is lost.

Any ideas on how to do it? I just don't want the default window animation to be applied on that.

EDIT

Doesn't seem to work:

enter image description here

share|improve this question
add comment

1 Answer

You might be able to do it through ccsm. In the animations plugin, you can add specific rules for specific programs or classes of programs:enter image description here

Clicking on "New" will bring up this dialog:

enter image description here

If you click on the + sign to the right of "Window Match" you will (finally) get to this window:

enter image description here

If you now click on "Grab" and then click on the menu you are referring to, the "Value" field will be populated with the ID of that menu and you can then apply specific animation settings to it. You may have to apply them to chromium as a whole if the drop-down list is not clickable but this should help you get started at least.

share|improve this answer
    
Doesn't seem to work ... uploaded a screenshot –  warl0ck Dec 7 '12 at 6:40
    
@warl0ck You might try disabling effects for all drop down menus using something like this in the "Window Match" field: (type=Menu | PopupMenu | DropdownMenu | Dialog) –  terdon Dec 7 '12 at 15:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.