Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I fix this SSH problem?

SSH debug errors

When issuing ssh -vvv user@host the output includes the following debug messages:

[...]
debug3: Incorrect RSA1 identifier
debug3: Could not load "/home/user/.ssh/id_rsa" as a RSA1 public key
[...]
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_1000' not found
[...]

The symptom of the problem

My SSH keyring is not automatically unlocked at system login. I'm asked for the passphrase each time.

My temporary fix

I give the command ssh-add I will no longer be asked for my passphrase for the rest of that session.

Running on Linux Mint.

share|improve this question
    
You seem not to have any ssh key agent running compatible with your desktop environment. Do you have any SSH client configuration set? (~/.ssh/config, /etc/ssh/ssh_config) And you can disable GSS/Kerberos authentication by specifying Host * (newline) GSSAPIAuthentication no in this configuration file. –  gertvdijk Dec 5 '12 at 12:01
    
I disabled the GSS authentication as you advised. Those warnings are no longer showing, but my SSH agent problem persists. I'll continue to look at that now. –  eoinoc Dec 5 '12 at 20:17
    
The /etc/ssh/ssh_config file does have the following settings (I presume GSSAPIAuthenticaiton no overriding this from ~/.ssh/config). SendEnv LANG LC_*, HashKnownHosts yes, GSSAPIAuthentication yes and GSSAPIDelegateCredentials no. –  eoinoc Dec 5 '12 at 20:20
    
Would the following indicate that I have an agent running? If not, it's possible I don't have "any ssh key agent running compatible with my desktop environment". sudo echo $SSH_AUTH_SOCK !5123 /tmp/ssh-[me-snip-for-security]/agent.2857. –  eoinoc Dec 5 '12 at 20:39
2  
Those messages are not relevant. The ones about RSA1 are expected: SSH looks if you have a key for the SSH v1 protocol, and you don't (you have a key for the SSH v2 protocl), which is fine because SSH v1 has been obsolete for years. The GSS warnings mean that SSH tried GSS authentication and didn't fine any credentials, which is fine since you didn't expect GSS authentication to work. That your keyring is unlocked is actually unrelated to ssh (since it works when you run ssh-add, ssh can contact the client just fine). It's a problem with the keyring program. –  Gilles Dec 6 '12 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.