Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Is there any way to prevent mc from taking 10-30 seconds to open? Never seen this with Debian.

share|improve this question
Did you compile it with --enable-vfs-smb? Try disabling the feature. Seems to be a common problem with version 4.8.4: mc starting up very SLOW –  Marco Dec 3 '12 at 12:25
Run strace -r -tt -o mc.strace mc to see where it's taking time. Upload the trace file if you need help interpreting it. Note that the trace file may contain private information (at least file names), take a look at it and sanitize it if necessary before uploading. –  Gilles Dec 3 '12 at 21:38

3 Answers 3


host 'hostname'

get quick result MC use hostname at first to connect to internal service

In similar situation on Fedora 18 I add hostname to /etc/hosts and it help.

share|improve this answer
mc internal service? may be we could change some configuration to fix mc to not require changing /etc/hosts? or is the /etc/hosts broken and mc expects it to be corrected? –  Aquarius Power Jan 22 at 21:20
oh, I just found that this works here: alias mc='TERM=linux mc' –  Aquarius Power Jan 22 at 21:29
Really /etc/hosts is broken, from some point of view. Impossible to resolve own hostname to own ip. I don't know why mc depend on it there. –  mmv-ru Jan 22 at 22:32

Actually editing /etc/hosts solved the problem for me.
My mc took 10 seconds to start due to the fact that during startup mc tries to resolve the local hostname to an IP address.
I added to /etc/hosts the following line (my hostname is FOO) FOO.domain FOO That instantly solved the problem.

share|improve this answer

Try to delete line "search whatever.something" from /etc/resolv.conf

/etc/hosts should have the lines: localhost hostname.domain hostname

"hostname" is your hostname and "domain" is your domain.

share|improve this answer
That makes some sense only if the machine is never connected to the 'net. That file is filled in by DHCP (or when the Internet connection is configured). –  vonbrand Jan 26 '13 at 3:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.