Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an small server in my house with an external usb 2TB hard drive:

/dev/sdb1: LABEL="Data" UUID="eedc3098-221d-4800-b8b4-efa4fef23f5f" TYPE="ext4"

I have the next line in /etc/fstab:

UUID=eedc3098-221d-4800-b8b4-efa4fef23f5f /home/data ext4 defaults 0 2

When I boot the system I get the next error:

Unable to resolve 'UUID=eedc3098-221d-4800-b8b4-efa4fef23f5f' fsck died with exit status 8

Then, the system ask me about root password for maintenance. If I log in like root and type:

fsck.ext4 'UUID=eedc3098-221d-4800-b8b4-efa4fef23f5f'

I get:

Data: clean 99709/122101760 files, 232470354/488378368 blocks

If I say to fsck to not ckeck the filesystem on startup (changing last 2 into a 0) the system starts properly (with the warning: special drive UUID=eedc3098-221d-4800-b8b4-efa4fef23f5f doesn't exist) and my partition doesn't mount. But the uuid exists in /dev/disks/by-uuid

How can I mount my drive properly? I thoght that maybe it can be a problem related with USB

share|improve this question

migrated from serverfault.com Dec 2 '12 at 14:10

This question came from our site for professional system and network administrators.

    
Does it mount when you type mount -a? –  jippie Dec 2 '12 at 14:56
    
Now what OS/distribution is that? –  ott-- Dec 2 '12 at 19:38
    
Debian 6.0 kernel 2.6.32-5-686 –  Freefri Dec 3 '12 at 14:41

1 Answer 1

up vote 1 down vote accepted

The problem might be that the drive needs to be initialized by the USB driver and this initialization takes time, so that when the partitions in fstab are mounted, the drive isn't ready yet, but by the time you log in, the drive is ready and mounting or fsck works.

If this is the problem, try adding the option noauto in /etc/fstab and mounting the drive manually later in the boot sequence, for example in /etc/rc.local (or whatever your distribution offers). Alternatively, add noauto in /etc/fstab and tell udev to do the mounting, with a line like this in /etc/udev/rules.d:

KERNEL=="sd?", PROGRAM=="/sbin/blkid -o value -s UUID %N1", RESULT=="EEDC-3098", RUN+="mount /home/data"
share|improve this answer
    
adding the option noauto in /etc/fstab and mounting the drive manually later in the boot sequence, for example in /etc/rc.local it worked. Thx –  Freefri Dec 29 '12 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.